Cannot register my MKR WAN 1300 board

I have successfully registered my Arduino Pro Gateway and it has status "Available", but cannot register my MKR WAN 1300 board in the device manager of the create web environment. The 1300 board is plugged into an USB port of my pc (Windows 10 OS) and appears to have been detected by the create environment. I have given it the name "WAN1300" in the first step of the registration process, but when i click on the "Register" button i get the following error message:

"We were unable to upload the sketch to get the DevEUI from your board."

I have confirmed that the board IS connected by starting the Arduino IDE and inspecting which COM port it has been detected on (COM11). I have also uploaded the "get_dev_eui_from_mkr_wan by albertian" sketch to find its DevEUI (which according to the results of running the sketch is a8610a323322780a). I am sure that nothing else is using this port (i closed all open Arduino IDE windows after successfully uploading and running the sketch - prior to numerous new attempts at registering the board in the create environment).

I have also tried pressing the reset button on the 1300 twice and retrying the process, but the result is the same. I actually tried this multiple times.

Hope someone is able to assist me in registering the board successfully. Thanks in advance.

Update: This problem is solved. The problem was due to me not installing the Arduino Create plugin as Administrator on my pc. The MKR WAN 1300 device is now registered properly.

Thanks for taking the time to post an update with your solution rasardray! I'm sure others who have the same problem and find this thread during their research will be very grateful. I'm glad it's working now. Enjoy!