Cannot reset UNO board

Hi guys,

I have recently started using an Arduino UNO board for a camera controlling project. I am just getting used to the code so forgive me if I've made some beginners errors!

I have uploaded one of the pre-loaded sketches within Arduino. File\Examples\Stepper\stepper_oneRevolution This worked fine and was uploaded to the board sucessfully, but now I cannot seem to stop the stepper motor running other than removing the power supply. I have tried the Reset button which only appears to pause the motion, which then continues as the button is released. I have also tried holding the button and removing the USB which did not stop the motor from running when the power was plugged back in.

Also, I have notices that TX and RX are not responding to uploads as the lights do not come on. I would like some advice on how to stop a sketch from running and also how to upload a new file onto my UNO board.

When trying to uload a sketch on top of the code already present in the momory of the board, I get the error code: avrdude: stk500_getsync () : not in sync: resp=0x30

Could somebody please tell me what this error means and how I might go about solving it.

Thanks a lot!

Press & Hold the reset button. Down a different sketch,like Blink. When the IDE says "Compiled xxxx of 32xxx bytes" release the reset button. May take a couple of tries to get the timing right.

I try and not to use D0, D1 for anything so that the Serial monitor can be used for debugging. If you do need to use the pins, try to use Rx, Tx as Output pins so the port can be used for Serial downloads and not have external hardware interfere. Helping out with reset may be necessary if you have the Rx pin blasting stuff out in your sketch.

cam-man6, Read Nicks excellent guide for getting help here http://arduino.cc/forum/index.php/topic,148850.0.html

Just a quick guess, you mis-wired something and burned up the USB chip on the UNO. TomJ

Disconnect the motor! Then try to upload the Blink example, following CrossRoads' suggestion to find a proper timing between manual reset and upload. If it doesn't work perform the loopback test because it can be a communications error.

@CrossRoads I had a look at the sketch and apparently only pins D8 through D11 are involved.