Cannot run include files. Getting 'No such file or directory' for any include.

I am using an Arduino Due with Arduino 1.5.1r2 running Windows 7. I have installed the drivers and communication with the hardware works fine. However, whenever I try to make a reference to any include file (files that it was installed with or libraries I download and try), I always receive the same error:

No such file or directory

I tried compiling the example Sketch located at Files - Examples - Starter Kit - p05_ServoMoodIndicator.
This same sample sketch works fine for under the Mega, but not the Due using the same code.

When I look at Sketch-Import Library, it shows a list of libraries I can reference. When I try those, I get the same error message.

Can anyone help me understand why no include files can be referenced correctly?

The example you reported use the Servo library that is not available for the Arduino Due right now. Many libraries that uses specific registers or capabilities of 8-bit AVR architecture (Arduino Mega and Arduino Uno boards) must be ported to the equivalent 32-bit SAM3 architecture to be used in Arduino Due.

Servo and Tone are two of them.

A porting of Servo library is available and will be included in the next release (1.5.2).
Tone is still not ported and is planned for 1.5.3.