Cannot run program "{runtime.tools.avr-gcc.path}/bin/avr-g++"

Hi,

Arduino: 1.6.3 (Windows 7), Board: "Arduino Uno"

When I try to upload 'Blink', it fails and the following error message appears:

Cannot run program "{runtime.tools.avr-gcc.path}/bin/avr-g++": CreateProcess error=2, The system cannot find the file specified

Can anyone help me understand why this is happening?

Thanks.

i recommend to download arduino version v1.0.5 & 1.0.6 the above ide is under development satge http://arduino.cc/en/Main/OldSoftwareReleases i shared download link. if any error let us know

I have the same problem. Really still there is no decision?

same problem any suggestion? (I try with both version 1.6.4 and 1.6.5... with deinstal/instal couple time and same error)

well... I started Arduino software from another user profile (on the same pc) and everything pass withou problems. So, error is in my pc/user profile. Just to find where is

Hello, I've got the same problem after installing 1.6.5.

The solution was, I've got a roaming-problem. So my "preferences.txt" resists twice on my Pc. One in the original installation directory an another in "C:\Users\AppData\Roaming\Arduino". So the IDE always use the one in the roaming directory. This is a Windows behaviour. Solution: Delete the whole Arduino Folder in the roaming Directory and everything works fine.

I am having the same issue. I have just upgraded to El Capitan (OS X 10.11) so maybe that has something to do with it.

I also had this issue after an upgrade to El Capitan and from Arduino 1.0.5 to 1.6.5. I have read https://github.com/arduino/Arduino/issues/2982 and https://github.com/arduino/Arduino/wiki/Arduino-IDE-1.5-3rd-party-Hardware-specification and fixed it the following way. It is a terrible fix but it worked. There must be a better solution. But anyway, this is how:

  • get http://brew.sh/ if you don't already have it
  • Install AVR compiler: $ brew install Caskroom/cask/crosspack-avr
  • Install avrdude (AVR uploader?) $ brew install avrdude
  • Close Arduino App
  • Open /Applications/Arduino.app/Contents/Java/hardware/arduino/avr/platform.txt (assuming your Arduino app is in the Applications folder)
  • find "{runtime.tools.avr-gcc.path}" and replace with "/usr/local/CrossPack-AVR"
  • find "{runtime.tools.avrdude.path}" and replace with "/usr/local/CrossPack-AVR"

Good luck!

Thanks very much. It's solved my problems

“Long Path Tool” is very helpful for this error !
best solution for your problem.

I just encountered the OP's problem, after downloading the latest Arduino IDE (at the time of writing 1.8.2)

I didn't have to install avrdude or brew. All I had to do was replace two properties:

(Assuming the Arduino app has been moved to /Applications)

In /Applications/Arduino.app/Contents/Java/hardware/arduino/avr/platform.txt compiler.path=/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/

In /Applications/Arduino.app//Contents/Java/hardware/platform.txt tools.ctags.path=/Applications/Arduino.app/Contents/Java/tools-builder/ctags/5.8-arduino11

Credit: https://github.com/Sloeber/arduino-eclipse-plugin/issues/236