Cannot see Duemilanova or Diecimila on my MacBook Pro (Yosemite)

I’m going crazy!!! Please help!

I’m trying to connect my old Duemilanove and Diecimila boards to my MacBook Pro running Yosemite but they never show up in the Arduino IDE.

I tried installing the latest signed drivers (http://www.ftdichip.com/Drivers/VCP.htm) but it did not change anything.

When I run kextstat | grep FTDI in the Terminal, this is what I get (sometimes):

164 0 0xffffff7f831fc000 0x7000 0x7000 com.FTDI.driver.FTDIUSBSerialDriver (2.3) <127 39 5 4 3 1>

If I run ls -al /dev/tty.usb*, I get no results at all.

I tried various things I read from various forums but nothing worked. These boards were working fine when I used them a couple years ago.

Ideas ?

P.S. I attached a screenshot of the OS’s hardware screen. TIA.

I just re-ran kextstat | grep FTDI and now, I get two entries:

162 0 0xffffff7f8317a000 0x7000 0x7000 com.apple.driver.AppleUSBFTDI (1.0.1b16) <138 39 5 4 3>
163 0 0xffffff7f83181000 0x7000 0x7000 com.FTDI.driver.FTDIUSBSerialDriver (2.3) <138 39 5 4 3 1>

I finally was able to fix it. I had to disable the FTDI kext bundled with Mac OS X.10 by renaming :

/System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBFTDI.kext
to
/System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBFTDI.disabled

I also had to rename what I think was a previously installed driver:

/Library/Extensions/FTDIKext.kext
to
/Library/Extensions/FTDIKext.disabled

With only the official and signed one installed (http://www.ftdichip.com/Drivers/VCP.htm), everything is now working properly.

Hope this helps somebody.

P.S. The good one is installed here: /Library/Extensions/FTDIUSBSerialDriver.kext