Cannot See genuine Arduino MKR 1010 WiFi on Mac Mojave or Mac Hit Sierra

HI downloaded software installed and tried to upload script. IDE cannot see arduimon on USB and it does not appear computer sees it either

Genuine board from a genuine shop Bose USB speaker cable so it is a data cable

I reported this as a bug but though I should also post here

Thanks if you can help Russell

russell_roberts bug report for this on GitHub: https://github.com/arduino/Arduino/issues/9136

What exactly do you mean by "IDE cannot see arduimon on USB"?

I have the exact same problem. All of my other boards work well.

I had discussions with support I have returned it to supplier as faulty for a replacement

Hi My board was faulty.

I could not see it in the ice or as a USB device in mis os "About this mac"=> "Systems report".

so I contacted Arduino support followed their questions & they advised it was faulty so I sent it back to supplier for replacement this worked fine.

Do you have a second Arduino you can swap out as a test of your cables etc?