Cannot select serial port in IDE. Linux environment.

I am using Kubuntu 18.04, recently upgraded the distro (not fresh install) Now I cannot select a serial port at all in the Arduino IDE. I can't get a list when I hover over the Tools > Serial port, it does not even highlight. When I upload I get "Serial Port not found '/tty/ACM0'..." but ls -l reveals it exists.

Permissions are correct and my user is in the correct group. I have tried a UNO R3, Cloned R3, Cloned Uno R1, Leonardo, and a Nano. Same result every time.

I can program using the USBasp,

Has anyone else experienced this specifically? And have any possible solutions?

I thought maybe missing packages, so I have reinstalled through the distro.

OK, right after I posted, and really thinking it was a package issue, not environment, I installed the latest Arduino IDE from here and setup.

I had to add my user to the tty and uucp group as I wasn't before.

It now works.

The Kubuntu distro version is 1.0.5, quite behind the current 1.8.8 from here, but without the package, updates mean I have to do it myself.

I am going to look for a current repo/ppa for Arduino IDE, if any one here has a good reliable repo/ppa let me know, thanks.