Cannot setup board for Arduino IOT Cloud

I tried setting up one of my Nano RP2040 Connect for Arduino IOT Cloud, it detects it but fails to upload sketch and get this error. I have restarted the Create plugin and reconnected the board to no luck at all

There is no issue with my PC or USB port as i can setup 2 MKR boards without issue

from the degug console

list

Network Ports:
[]

Serial Ports:
[
  {
    "Name": "COM18",
    "SerialNumber": "",
    "IsOpen": false,
    "VendorID": "0x2341",
    "ProductID": "0x005E"
  }
]

{
  "Cmd": "Serial",
  "ProgrammerStatus": "Starting"
}

{
  "Msg": "Restarting in bootloader mode",
  "ProgrammerStatus": "Busy"
}

{
  "Msg": "Flashing with command:C:/Users/gamin/.arduino-create/arduino/rp2040tools/1.0.2/rp2040load.exe -v -D C:/Users/gamin/AppData/Local/Temp/arduino-create-agent768831581/sketch.elf",
  "ProgrammerStatus": "Busy"
}

{
  "Msg": "rp2040load 1.0.1 - compiled with go1.15.8",
  "ProgrammerStatus": "Busy"
}

I have exactly the same problem... I get the same error. Couldn`t setup nano rp2040 connect but my nano 33 IoT boards are working well.

Yep, same problem here.

Got it working, think Arduino need to add some info to let people know what to do when setting up the board

All I done was put the board in to boot loader mode, double tapping reset button.

I encounter the exact same issue/error. Could you please explain the exact procedure, when to double-click, etc, please? ... Lost tried a lot of combinations and timings, no GO until now, and this on 2 different PCs...

Thanks in advance.

Make sure Arduino Create Agent is installed - https://create.arduino.cc/getting-started/plugin/welcome

Make sure you have installed the Arduino Mbed OS for Nano Boards

plug in the Nano RP2040

Go to IOT Cloud devices https://create.arduino.cc/iot/devices

Add a device > Setup an Arduino board

Let it detect your device

Double tap the reset button on the Nano RP2040 Connect

Click Configure

Give your board a name

Click next

some times it takes a few attempts but very unstable at best

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.