Cannot upload Arduino Duemilanove

Hello to all,
Couple months ago i got my duemilanove, uploaded some programs, tested analog inputs, then i stored in its shielded bag, yesterday i opened it and i got this error.

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Below, my screen shot for the port settings. it doesn’t appear but RTS is checked and also serial enumerator

I spent my entire day getting it work. but no luck so far. i tried every suggestion in this forum. still no luck.

I am using windows 7, i have the latest drivers, so i am using the same hardware as i was using before (when it worked)

i tried this thread also
http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1261558824/4

I have to submit my project by January 5. So i cannot order a new one. my computer doesn’t have parallel port. so no burning bootloader:(((
Please HELPPPPPPP :’(
Thanks

Have you tried a manual reset of the board ?

Auto reset may not work for some reason.

There is a small solder jumper by the USB port, check that the pads are still attached together with solder.

Mowcius

Madworm - I tried pressing reset : 2sec before uploading, 1 sec, same time, 1 sec after, 2 sec after 3 sec after. (and other combinations, like pressing until i see a dim flash from RX led) it seems like pressing reset doesn't do anything (i tried the pin reset as well)

Mowcius - Do you mean "RESET_EN" ??? as far as i can see there is a thin solder in between the two bumps. I tried connecting them both by putting wire on top. it didn't work either.

I don't know if that is something but, i took out the Atmega 328 chip to see error messages. i still get the same error message:( and i did not mention before, the TX RX leds are dim when RX flashes 3 times during upload. can it be a power problem? all the power output pins work.

Hace you tried using: Different USB port? Different USB cable? Different computer?

Mowcius

I tried with an imac. couldn’t make it work:( i tried different cable and all the ports in the computer. i will try it on another windows pc in a minute. i will let you know how it goes. if that doesn’t work do you think http://www.geocities.jp/arduino_diecimila/bootloader/index_en.html
That idea is good?
:-/

OK i tried with Xp, doesn’t work. same error. i wish there was a guide explains what is the expected and what is the responded value. like error code database.

As you've mentioned that the RX/TX LEDs are dim, does that change if you try uploading (just as a test) with the ATmega328 chip removed ?

Of course this won't work, but are the LEDs any brighter ?

What you can also do is a loop-back test (with the ATmega chip removed). This can verify if the USB/serial chip is still OK. To do so just place a wire between digital pin #0 and #1 and use a terminal program to send text to the board. If all is well, the text should be echoed back to your screen with both RX and TX blinking happily while you're typing. If this test is OK, then the problem is with the ATmega chip.

As you seem to have tested the manual reset quite extensively, maybe it is time to get a new chip. Or try the link you've posted. Some people have used it on windows successfully.

Hey madworm, Lights were equally bright in both cases (chip removed and installed again).

I did the loop-back test. TX/RX leds were on whenever i send something. And the brightness of TX/RX seemed to be depended on the amount of data i sent (longer sentences = brighter and longer shining led)

The method on the link i posted did not work. my chip's id# is 0xffffff and expected something else. so i am out of options.

Hi, same issue on my Arduino 2009 board. Try also to burn a new bootloader with Arduino IDE 0017 and AVR Studio 4.17. They both failed, AVR studio with AVRISP mkII says: "A problem occurred when executing the command. Make sure that you are using the correct programming method. Current mode is ISP. See the command output for more info." I've tried to setup each ISP clock frequency, same error.

Trying to burn bootloader from Arduino IDE I get: avrdude: usbdev_open(): did not find any USB device "usb"

Choosen the right board, com port and AVR ISP type.

Maybe the board is defective? Does a health check tecnique exist?

Thank you

/me

Had same problem. I tried baud rates to no avail then went back to Blink program and changed the com port under tools (sure I tried this earlier too) and it now works. Brand new here but hope this works for you. I am on Vista and the computer is happy using its own driver rather than the downloaded one with the Arduino program.