Cannot upload code

Hi!

Im triying to learn more about RFID reading and writing on T5557 cards. I'm using this tutorial

The diference is that the arduino i'm using is the Arduino Mega 2560

Using the IDE Arduino 22 and the code to to read and write the T557 cards.

The problem is that when I try to upload the code even without the RFID shield it gets stuck. The message "Uploading" keeps apearing but I have waited 30 minutes and nothing else happens.

Triying to find the source of the problem. I tried the inverse engeneering and reached the next conclusion.

If I comment the last 3 lines on the loop():

   Serial.println();
   Serial.println("Card ready!!!");
   
   delay(5000);

The code is successfully uploaded.

Does this code reachs the limit of memory from the Mega 2560?

Is it something else?

thanks in advance

AH! It's the dreaded "Three Exclamation Marks" problem. There is a version of the bootloader that implements a local debug program that is activated when three '!' characters in a row arrive at the serial input. Change it to two '!' and it should work.

Hey! thanks!!! Worked like a charm!!

Sorry for the delay :slight_smile: