cannot upload program in the second time

Hello,

I am trying to send a program to Arduino via USB. It succeeds in the first time after I connect the cable, but fails in the second time. Once I disconnect the cable and connect it again, it succeeds.

This didn't happen in the past. It looks like a regression.

The following is the error message:


Arduino: 1.6.3 (Mac OS X), Board: "Arduino Pro or Pro Mini, ATmega328 (5V, 16 MHz)"

Sketch uses 1,118 bytes (3%) of program storage space. Maximum is 30,720 bytes. Global variables use 9 bytes (0%) of dynamic memory, leaving 2,039 bytes for local variables. Maximum is 2,048 bytes. avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00 Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with "Show verbose output during compilation" enabled in File > Preferences.

I solved it by myself. I worked after I installed FTDI driver.

I came across this post, and I'm having the same issue. But installing the latest FTDI driver from here:

http://www.ftdichip.com/Drivers/VCP.htm

didn't' solve my problem. I'm trying to program an Arduino Pro Mini on a Mac running Yosemiti. The first time I upload a program, everything works fine. But if I keep everything the same, and upload the same program an instant later, I get the "avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xe0" error. And I won't be able to reload a program until I unplug my board from my computer and plug it back in.

Any thoughts on what could be the problem?