cannot upload sketch to my arduino uno

I've been trying to upload the blink example to my freeduino usb but the compiler displays the following message:

Binary sketch size: 1,072 bytes (of a 32,256 byte maximum)
avrdude: stk500_recv(): programmer is not responding

I'm sure that I've configured the board correctly for I was able to upload and run sketches the previous day.

When i press the reset button nothing seems to happen; normally the led connected to pin 13 should blink.
I've tried the loopback test as per the following instructions:
http://forum.arduino.cc/index.php?topic=73748.0
and the serial to usb /serial part seems to work fine.

Is it atmega 328 that is not working then ? Is there any way i can test the microcontroller (I don't have another one to substitute)

glamis

Did you try searching the board? This or similar errors comes up a fair amount of times.

Your Arduino probably has a counterfeit FTDI chip. Windows may have updated the driver, which doesn't seem to work with the counterfeit chips. Download and install an older version of the driver, it worked for me. I bought a couple of Nanos that won't work with the latest driver, but do with the driver downgraded.

Information in this thread:
http://forum.arduino.cc/index.php?topic=198681.msg1477473#msg1477473

Thanks for the suggestion but I'm using linux operation system and the driver shouldn't be a problem and moreover the serial loopback test is working fine.

glamis

That is the kind of important information that should be included in your original request for help.

I don't know if the driver issue with counterfeit FTDI chips is a problem in Linux, or not. I think it is only a problem with the Windows drivers because I suspect the driver update is there specifically to make the counterfeit chips not work.