Cannot upload sketch

Hello everyone
I really am an old aging newbie trying to use an Arduino Mega 2560 board.
The operating system i am using is Ubuntu 16.04.
The problem i keep getting when i upload a sketch is:

The serial port avrdude: stk500v2_ReceiveMessage(): timeout does not exist or your board is not connected.

When i opened the Arduino IDE i selected my board from the list: Arduino/Genuino Mega or Mega 2560

There were only two options available for port selection so i selected:

/dev/ttyACMO(Arduino/Genuino Mega or Mega 2560)

I would really appreciate any help or advice thanks!

I have followed the tutorial at https://www.arduino.cc/en/Guide/ArduinoMega2560 and this time when i try to upload the "Blink" sketch i get the following message:

The selected serial port avrdude: stk500_send():failed

I have also tried disconnecting the mega2560 board when powered up and the port option that disappeared was:

/dev/ttyACMO(Arduino/Genuino Mega or Mega 2560) It is the option i have choosen.

Would someone tell me what i am missing or doing wrong please.

After having tried everything i could possibly think of and failing i even tried downloading the official software at least three times and i still couldn't get it to work. So in deparation i went into the Synaptic Package Manager and downloaded Arduino 2:1.0.5+dfsg2-4. Setup my board and port and success at last! My Arduino Mega 2560 is now rocking. And without a word of encouragement or help from the Arduino community.