Cannot upload sketches to Arduino BT with Ubuntu 10.10

I have spent a good deal of time trying to get this device to work with my linux box, and I was hoping somebody could provide some insight.

So far, I have managed to pair with the Arduino, create the /dev/rfcomm0 device with the bind command as stated on the "getting started" page. I have installed the Arduino package, and can open the IDE no problem.

The problem is when I try to upload a sketch, all I get is

avrdude: ser_open(): can't open device "/dev/rfcomm0": Host is down

I can ping the device with l2ping. I can see the rfcomm0 device (but when I try to do anything with it, also with the "host is down").

What am I missing? I plugged the thing into the Windows XP box right next to it with the same BT module and it works fine.

Help?

I've sometimes had luck resetting the board shortly before uploading. But I haven't tried on Linux (only Mac OS X).

Well I tried opensuse to see if ubuntu was the issue with connecting my Arduino to my laptop, but it had the exact same problem, and same error.

At this point, I'm not sure if there is a way to get it connected with an usb Ezurio module.

Does anyone know what exactly the "host is down" message above means?

-Karl