Cannot upload sketches

Hi,

I have recently bought a new Arduino Uno R3 after i burnt my previous one out.

I cannot upload sketches and I cannot work out why.

I have the correct com port selected and I have the correct board selected.

"avrdude.exe: stk500_getsync(): not in sync: resp=0x00" is the message i receive.

I have tried the "loop-back test" and that works. I have a feeling its a problem with the bootloader because when i press the reset button, none of the lights blink.

Can someone please help me?

you could try another 328 chip to replace the existing

I replaced the Arduino and everything worked. Either the bootloader hadn't been burned to the chip or the chip was faulty.

Hi,
Was this a cheap Chinese version? I got myself a cheapy Nano from China that too did’ent seem to work, or should I say allow me to upload anything to test it, not even a simple blink. The problem I discovered later was it had no bootloader. So using another Nano I was able to use one to download the bootloader to the new Nano, and it’s worked well ever since.

Hope it helps, regards.

Mel.