Cannot upload to Leonardo on Ubuntu 14.04

I just received my Arduino Leonardo and wanted to upload an example program onto it.
I am using Ubuntu 14.04 and tried different versions of the Arduino IDE.
What do I have to do to be able to upload programs to my Leonardo

However, it doesn t work. I keep getting the following error messages:

avrdude: Version 6.0.1, compiled on Jan 15 2015 at 13:12:29
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "/home/myusername/Programme/Arduino/arduino-1.7.10-linux64/hardware/tools/avr/etc/avrdude.conf"
         User configuration file is "/home/myusername/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/ttyACM0
         Using Programmer              : avr109
         Overriding Baud Rate          : 57600
avrdude: ser_open(): can't open device "/dev/ttyACM0": Device or resource busy
avrdude: ser_send(): write error: Bad file descriptor

What I have already done is:

  • reinstalling the Arduino IDE multiple times and rebooting my system afterwards
  • using an external voltage supply
  • I chose the 'Arduino Leonardo' as Board
  • I chose 'dev/ttyACM0 (Arduino Leonardo) as port
  • I looked for solutions on the internet, tried some suggested ones, but none worked
    - I installed 'hardinfo' from Ubuntu Software Center (kind of a 'device manager'), it shows me the Leonardo connected as a 'keyboard'
  • I asked a friend who has an Arduino UNO and uses Ubuntu as well, he didn t know what to do

OK, I found a solution, I removed a program called ‘Modem Manager’ from my computer using the terminal.