Cannot upload to Mega 2560 with IDE 0018

Hello: I'm trying to develop a project using IDE 0018 with anArduino Mega2560, but I get the following errors:

avrdude: stk500_getsync(): not in sync: resp=0xce avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

I suppose it is due to the selection of the board in the IDE, but I cannot see the correct one in the menu. Is there a way to solve the problem?

Thank you Rafael

Time to update your copy of Arduino software. Version 18 (2010.01.29) is almost two years old now. Support for the 2560 was added in version 20 (2010.09.27).

It might be time to 'bite the bullet' and update to the 1.0 release.

Yes, I'm also using it for other projects, but I want to use Ribbotson's code for Bluetooth PS3 controller and I think it is only compatible with version 0018.

Regards Rafael

Try it with version 22 or 23, you may have good luck there.

I tried version 20 and Mega 2560 appears for uploads, but the library I'm trying to use gives compiler errors. In one of the blogs I visited, Oleg says that probably version 18 is the latest that works.

Rafael