cannot upload to mini-pro

i bought a cheap usb FDTI cable on ebay.. 6 pinout as follows: Red wire: 5V Black wire: GND White wire: RXD Green wire: TXD Yellow wire: RTS Blue wire: CTS

nomenclature is different from what is listed for the arduino mini pro.. the six pins are: gnd CTS VCC TXO RXI DTR

gnd and vcc i have OK.. tried various other connections.. no go.. i am assuming TXO is TXD and RXI is RXD but must not be, because i have swapped around the remaning 2 wires and still no go.. any help please--

backwoodsjack: i am assuming TXO is TXD and RXI is RXD

Nope, other way around. TXO (transmit out) goes to RX RXI (receive in) goes to TX

Problem is probably in not having a DTR. But I thought RTS should work for that as well.

For further help: - Do you have a link to the cable? - Did you do the loop back test? - Tested it with manually pressing the reset button? (Release it when IDE says uploading.)

thankyou.. i will try all these things.. much appreciate, sir.. ill get back with results..

thanks septilion… it seems to be failing the loopback test…
i jumpered green to white-- txd-rxd
and tried to run a terminal and do these commands–

cat /dev/ttyUSB1
echo “hi” > /dev/ttyUSB1

and i get nothing…
/dev/ttyUSB1 does show up in arduino IDE tools/ports…
when i plug it in…
i am running ubuntu 14.04…
this is the FTDI USB cable i got on ebay–
http://www.ebay.com/itm/121954707294?_trksid=p2057872.m2749.l2649&ssPageName=STRK%3AMEBIDX%3AIT

i probably bought a ‘window$’ only cable…

backwoodsjack: i probably bought a 'window$' only cable..

Nehhh, that does not exist. If it doesn't work on Linux it doesn't work at all ;)

But yeah, failing the loopback test then the error is probably in the driver part. Are you sure it's the right port? Aka, it's only there when the cable is plugged in? I'm a to big of a Linux noob myself to help you dive into drivers... Sorry.

I run Linux Mint.

I also bought a cable with FTDI on eBay. My adapter cable has DTR pin. The RTS pin is not the same as the DTR pin on the FTDI chip. http://sheekgeek.org/2010/adamsheekgeek/add-automatic-reset-to-your-ftdi-232r-cable