Cannot upload to Pro Trinket

Arduino: 1.8.5 (Windows Store 1.8.10.0) (Windows 10), Board: "Pro Trinket 5V/16MHz (USB)"
** Using Port : usb**
** Using Programmer : stk500v2**
avrdude: usbdev_open(): did not find any USB device "usb" (0x03eb:0x2104)
avrdude done. Thank you.
An error occurred while uploading the sketch

This is the message Im getting when I try to upload. It does compile successfully .

When I plug the usb into the Pro trinket and then into the computer, I do not get a 'ding' indicating the computer recognizes a device.

I also dont know which comm port is comm1

Any help would be appreciated. Thanks,

Matt

No ding on plugging the board in? Does it show up in device manager, maybe as an unknown device? Have you installed the drivers?

(deleted)

I did follow the instructions.

I downloaded the windows 'app', and the drivers, and it shows up there. However, I get the error code mentioned above.

Switched computers, downloaded the IDE, as well as the pro trinket driver, but the Pro Trinket is not showing up in the Tools>Board menu. And when I search the Boards Manager menu, the Pro Trinket is not there either.

(deleted)

(deleted)

Plugged in, I have a steady green light and a flashing red light. I press the reset button and I get a momentary solid red light followed by the flashing red light as before…

I have version 1.8.5, which is the latest.

After that, I downloaded the “windows driver installation”, which includes the Pro Trinket. I then restarted the computer, just to be sure. Still no Pro Trinket in the Boards menu

(deleted)

Actually, this is the second one I bought. The first one I did return, because it didn't pulse as per the youtube video. Do I have TWO bad boards in a row from the store?

(deleted)

(deleted)

Third Pro Trinket- its blinking exactly like the last two, so I am guessing that either its a very bad batch or this is how they are supposed to blink.

Very disappointed, to say the least:

  1. You say the Pro Trinket does not appear in your boards menu so this must be fixed first. Follow the Adafruit Pro Trinket instructions to the letter.

Oddly, your first message indicates you have installed the Pro Trinket board so I will continue.

Arduino: 1.8.5 (Windows Store 1.8.10.0) (Windows 10), Board: “Pro Trinket 5V/16MHz (USB)”

  1. When you use the Pro Trinket micro USB connector, there is no USB serial port. The Adafruit instructions say the following.

Next go into the Tools → Programmer menu and select the USBtinyISP programmer.

Plug in the Trinket, make sure you see the green LED lit (power good) and the
red LED pulsing. Press the reset button if the red LED is not pulsing, to get
into bootloader mode.

Click the Upload button (or select File->Upload)

  1. If all else fails, the board can be programmed using an FTDI cable.

https://learn.adafruit.com/introducing-pro-trinket/using-ftdi

  1. Get help from the Adafruit forum. The experts for this board work at Adafruit. Since this is your third board, I suspect the problem is failure to follow the Adafruit instructions.

Rather than the window store APP which a lot of people seem to have had issues with could you not install the REAL IDE for a better chance ?

Hey there, I know this post is old, but I've found a solution. If all the correct software is in place, but the light flashes and does not fade, it does not have a data connection. this is mostly caused by a bad cable. I find that the trinket and Pro Trinket are very flakey when it comes to this, and had to try 6 cables before I found one that worked.