Can't add libraries

i'm new at this.

Trying to add libraries in Arduino 1.8.0 running on Windows 10

First clicked on "Include Library" then on "Add zip library" the program immediately crashes.

Am I doing something wrong?

Thanks for any advice

Please attach the file you’re trying to install and I’ll see if I can reproduce the problem. If you click the “Reply” button you’ll see a link appear “Attachments and other options”, after you click that you will be able to attach the file.

Thanks for your response. I can't even get to the zip file I'm trying to add. After "include Library" then "Add zip Library" the program crashes.

OK, then we know it isn’t a problem related to that specific file. Please do this:

  • Run arduino_debug.exe, which is found in the Arduino IDE installation folder, from the command line.
  • Sketch > Include Library > Add .ZIP library
  • After the IDE crashes copy and paste all the output you see in the CMD window here using code tags (</> button on the toolbar).

Thanks again for your advice. The diagnostics indicate that the problems is with the Java Runtime Environment. I will pursue a fix for this.

I’m having the same issue. I’ve attached a log. I’m new to this and can’t get anywhere without the libraries installed for my project. Help is much appreciated <3

hs_err_pid13268.txt (29.7 KB)

I used my laptop and things went fine.. Also works on my girlfriends PC. Not sure what's wrong with mine :( I'm able to continue with my project but any help getting this to work on my computer is still very welcome!

Hi, I run into the same problem: I was running Arduino Version 1.8.1 (on Windows 10) and could not add any .zip-libraries anymore, so I updated to 1.8.2. Same problem. I cannot add any .zip libraries anymore.

I updated my Java Runtime Evironment to 1.8.0.131-B11 (uninstalled all old Java Versions before), updated the system environment variables, cleaned the registry, wipped off Arduino completely from my system and installed it back again ... Nothing helped.

Running arduino_debug.exe I still find the error message: Java(TM) SE Runtime Environment (8.0_111-b14) even though I don't have this JRE version anymore on my system.

A fatal error has been detected by the Java Runtime Environment :

EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x659f21f4, pid=12388, tid=0x00003484

JRE version: Java(TM) SE Runtime Environment (8.0_111-b14) (build 1.8.0_111-b14)

Java VM: Java HotSpot(TM) Client VM (25.111-b14 mixed mode windows-x86 )

Problematic frame:

C [msvcr100.dll+0x121f4]

:confused:

Any idea?

I’m having trouble with this as well. My IDE crashes immediately upon clicking “Sketch → Include Library → Add .ZIP Library…”. This happens when I’m using the IDE from the Windows installer, the Windows stand-alone zip, the Windows Store app, the hourly build, and even my own 1.8.3 build from Github.

I am running the latest Creator’s Edition build of Windows 10 (v1703).

I’ve done some research on the error that gets logged by the arduino_debug.exe (same error that others above are seeing, see attached hs_err_pid22448.log), and noticed that the error is always in the getDisplayNameOf method of the sun.awt.shell.Win32ShellFolder2 class.

It turns out that there is a bug in the JRE on Windows 10 v1703 (see here for an example). Some file chooser dialogs are crashing the Java Runtime on v1703 Windows if the application’s Look and Feel is set to either system default, or specifically the Windows look and feel. It doesn’t affect all file chooser dialogs, as I can still use “File → Open…”.

I was able to get the Add .ZIP Library menu item to work for me by forcing the IDE to use the Metal Look and Feel by modifying arduino-core/src/processing/app/Platform.java according to the attached patch.

Since this bug is caused by an interaction between two 3rd party softwares (JRE and Windows), it will probably go away on its own in time.

edit: Had to rename my attachments and had to wait 5 minutes before editing.

hs_err_pid22448.log.txt (27 KB)

override-look-and-feel.patch.txt (528 Bytes)

Nice investigative work there.

You can always manually install libraries into the libraries folder inside your sketchbook folder.

I also did upgrade to Windows 1703 and do have the same problem. :frowning:

Is there a detailed information for dummies like me how to compile the patch into arduino or how to add libraries (would it be simply enough to copy the files from the zip-file into the library-directory?) ?

Here's the instructions for manually installing libraries: https://www.arduino.cc/en/Guide/Libraries#toc5

Same problem here: After "include Library" then "Add zip Library" the IDE crashes.

Here's the debug output- looks like a Java problem? (How do I fix that??)

Looking for library 'user32'
Adding paths from jna.library.path: null
Trying user32.dll
Found library 'user32' at user32.dll
Looking for library 'shell32'
Adding paths from jna.library.path: null
Trying shell32.dll
Found library 'shell32' at shell32.dll
Looking for library 'Ole32'
Adding paths from jna.library.path: null
Trying Ole32.dll
Found library 'Ole32' at Ole32.dll
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x67f021f4, pid=12032, tid=0x000006d8
#
# JRE version: Java(TM) SE Runtime Environment (8.0_121-b13) (build 1.8.0_121-b13)
# Java VM: Java HotSpot(TM) Client VM (25.121-b13 mixed mode windows-x86 )
# Problematic frame:
# C  [msvcr100.dll+0x121f4]
#
# Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
#
# An error report file with more information is saved as:
# C:\Program Files (x86)\Arduino\hs_err_pid12032.log
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.java.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

Hi all. This sounds like maybe the same issue reported here: https://github.com/arduino/Arduino/issues/6398 which is caused by using Windows 10 "God Mode".

As the Arduino developer commented here: https://github.com/arduino/Arduino/issues/6398#issuecomment-319073269 they believe they have fixed this issue by updating JRE but, until the next release of the Arduino IDE, you will need to use the hourly (AKA "nightly") build to benefit from the change. The other solution should be to not use "God Mode".

I solved this problem by downloading this update here in the software download area.

ARDUINO SOFTWARE HOURLY BUILDS Download a preview of the incoming release with the most updated features and bugfixes.

Cheers.