can't burn bootloader - programmer worked B4

I'm trying to put bootloaders on some new ATMEGA168-20PU chips I got. I've burnt bootloaders before on other new mega168's with the current equipment I'm using but i'm not getting any luck.

Here's my setup: Arduino Diecimila home-made parallel programmer (from bootloader DIY) 12v regulated power input

Windows XP SP3 My parallel port is configured for ECP. I'm running 'GIVEIO' and i've even re-installed it. My registry is modified (DisableWarmPoll) parallel port configured for no interrupts and it sticks Arduino version 0016 Environment configured for Diecimila w/ 168

my error is something like this:

avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
avrdude: AVR device initialized and ready to accept instructions
avrdude: Device signature = 0xffffff
avrdude: Yikes!  Invalid device signature.
avrdude: Expected signature for ATMEGA168 is 1E 94 06
avrdude: verifying ...
avrdude: verification error, first mismatch at byte 0x0000
         0x00 != 0x07
avrdude: verification error; content mismatch

avrdude done.  Thank you.

Also, pin 13's LED turns on once the parallel programmer is inserted. I don't know if this means anything but I thought it was interesting.

I'm stumped. I've also tried it on another machine that's running Vista and still no luck. I've checked the programmer and resistors out, everything checks out.

thanks in advance.