Can't burn bootloader via ArduinoISP (Solved)

I have an ATMEGA328P chip with Arduino UNO Bootloader. I want to turn it to 8mhz with internal clock.
So I followed http://arduino.cc/en/Tutorial/ArduinoToBreadboard but I’m geting error during upload

avrdude: Yikes! Invalid device signature.
Double check connections and try again, or use -F to override
this check.

For ISP I use Arduino Duemilanove, 16mhz/5v


I only added a resistor for disabling reset

I found out that others also had the same problem but I did’n found any solution here, is something new with it?

Try running the Optliloader to program your blank part. No resistor needed.

https://github.com/WestfW/OptiLoader

Looks like you already have the connections needed.

Connect 13,12,11 to 13,12,11, master's 10 to Reset on part to be programmed

I've tried optiloader before. It is good tool, but it doesn't help in case of bare atmega (without oscillator). I realized that I can't configure Atmega to internal clock without uploading but I can't upload without set internal clock, looks like magic circle? :))) not at all :))) 1) Assemble circuit with oscillator (I used 16mhz); 2) Set board - Atmega 328 on breadboard (8mhz internal clock); 3) Burn bootloader; 4) remove oscillator and capacitors and Atmega will work with internal clock, now you can burn it without oscillator.

But I had also another problem, avrdude didn't recognize the Atmega, and with that optiloader I figured out that device code is 0x1E9514 (not as usual 1E950F) so, I changed avrdude config file and burn with oscillator worked ok.

Also fixed bug with pins_arduino.h library.

Now have new error during sketch upload

avrdude: stk500_getsync(): not in sync: resp=0x00

I'm succeed with rx/tx wiring Just don't sure which type of board I should choose when uploading a sketch, now I'm using "Pro or Pro Mini (3.3v, 8mhz) atmega328".