Can't burn to chip after using avrdude

I was following this guide for building a minimal Arduino: http://hcgilje.wordpress.com/resources/arduino-standalone/

I managed to get it to work using this command:

./avrdude -C ../etc/avrdude.conf -p m168 -c avrispmkII -U flash:w:./Blink.cpp.hex -U lfuse:w:0xE2:m -U hfuse:w:0xDF:m -v -P usb

The hardware I used was an AVRISPMKII plugged into the ICSP slot on my Arduino Duemilanove with an Atmega168.

I put the the chip back into the Arduino, the Arduino still runs the program I burned to the chip.

The problem is that I get an error if I try to reprogram the chip:

avrdude: stk500_recv(): programmer is not responding

I also can't use my AVR programmer through the ICSP slot on the Arduino to reprogram the chip:

         Programmer Type : STK500V2
         Description     : Atmel AVR ISP mkII
         Programmer Model: AVRISP mkII
         Hardware Version: 1
         Firmware Version: 1.05
         Vtarget         : 4.9 V
         SCK period      : 953.29 us

avrdude: stk500v2_command(): command failed
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.

What can I do to revert the chip to a state where I can burn to it again?

How about using the IDE to burn a standard bootloader back onto the chip ?

That worked, thanks Pluggy.

I had actually already tried to burn the bootloader again but it failed with a similar message. I tried it again today and it worked.

I also haven’t been able to ask a different Arduino board what its fuses are using avrdude.

This strange or intermittent behavior is making me thinking my programmer is damaged :-/