Can't communicate thru Atmega16u2 chip

Hi,
i'm having smal problem. When I try to send/recive data by Serial to USB by Atmega16u2 chip i'm getting only garbage. Can't do programming by programming port too. I'v flashed updated firmware form Arduino.. do 16u2 chip form https://github.com/arduino/Arduino/tree/master/hardware/arduino/sam/firmwares/atmega16u2 but no changes.

void setup() {
  Serial.begin(9600);
  Serial.write("USB 115200, Serial0 115200/n");
}

void loop() {
  Serial.write("USB 115200, out 115200/n");
  delay(10);
}
]/code]

have you set the baud rate for the serial monitor window to 9600 to match your sketch (at bottom of the window) ?

your simple sketch sets baud to 9600, but then sends messages about 115200 baud - seems strange?

also note:

  1. a line feed character is '\n' not '/n'
  2. delay(10); is only 10ms, too short a period between lines printed out for human reading

try using good old Serial.println("text string"); instead of Serial.write(), like this:

void setup() {
  Serial.begin(9600);
  Serial.println("Hello ....");
}

void loop() {
  Serial.print("looping ....");
  Serial.print("\n");
  delay(1000);                            // 1 second delay
}

Same with your code.
I’v tried all baud rates, and tried using putty too.
2016-09-05.png

why did you need to flash the chip ?
did it work before?
do you have another arduino that works on same port?

From start i had problem with uploading sketch on programming port.
Im only left with pro mini bards, and 1 uno with dead atmega328p chip.

When i put jumper on pin tx0 and rx0, chip is working.

bump