can't connect arduino(s)

I know this has been asked many times, but it seems that I cannot get this to work no matter what i do:

I had an arduino which I thought was fried, cause it would not connect to my pc (that is, i couldnt upload anything)… so i got a new atemga, stuck it in, and was still unable to upload code from my pc

then i got another arduino, and it wasnt able to get code from my pc either…

i changed the cable out, and tried a different pc for both boards… nothign works! does anyone have any idea what I can do?

EDIT//: I feel I should share this with you… I am the biggest failure on this forum - i have been pressing verify rather than upload to board for the past weeks, which is why it seemed that neither of my boards worked… uhhh, what a hair-pulling experience… :-[

HA!

Took some guts to admit that.

Man… weeks!

Well at least you’ve got some new hardware now too!

yea, i guess thats an upside… i still cant believe I missed that! what’s even worse is i realized my mistake by accidentally clicking the right button >:(

We’ve all had one of those “is it plugged into the wall” moments. My personal favorite was wandering around looking for a 1/2" and 9/16" wrench I’d just been using, getting rather ticked because they weren’t to be found, found something to substitute… and then reached into my pocket to get some change for a pop machine. Ummm, you can guess what my workmate had to say on that matter.

Anyway, 'duinos are like chocolates, you can’t only have one. Play with some TWI communications, etc. There are whole ranges of experiments that open up when you have more than one!

I’ve got an Arduino, 2 x Freeduinos and a Boarduino :slight_smile:

You can never have too many.

I had a chuckle at your mistake Jezuz!

I wonder if my significant other would buy that reason for me to order some more Arduinos? I mean it seems like a honest mistake. ;D

Lefty