Can't connect Nano 33 IOT to IOT Cloud

Hi, I'm trying to connect my Arduino Nano 33 IOT to the Arduino IOT Cloud. I have the Create Agent installed and running on my computer. Attempting to follow the device connection process at https://create.arduino.cc/iot/devices lets me get as far as selecting a name, shows a progress bar that gets up to the "Configuring secure element" status, and eventually kicks back this error:

Start command: exec: "{runtime.tools.fwupdater.path}/FirmwareUploader": file does not exist

The suggested troubleshooting steps of restarting the Create Agent and reconnecting the device to my PC both didn't work. Neither did restarting my PC entirely or pressing the reset button on the Arduino. I'm on Windows 10 2004 with Create Agent version 1.2.0-5c796d2. Here's a session from the Create Agent debug console while I was following the process:

{"Version" : "1.2.0"}
{"Commands" : ["list", "open [portName] [baud] [bufferAlgorithm (optional)]", "send [portName] [cmd]", "sendnobuf [portName] [cmd]", "close [portName]", "bufferalgorithms", "baudrates", "restart", "exit", "program [portName] [board:name] [$path/to/filename/without/extension]", "programfromurl [portName] [board:name] [urlToHexFile]"]}
{"Hostname" : "sakamoto"}
{"OS" : "windows"}
list
{ "Ports": [], "Network": true }
{ "Ports": [ { "Name": "COM3", "SerialNumber": "", "DeviceClass": "", "IsOpen": false, "IsPrimary": false, "Baud": 0, "BufferAlgorithm": "", "Ver": "1.2.0", "NetworkPort": false, "VendorID": "0x2341", "ProductID": "0x8057" } ], "Network": false }
downloadtool windows-drivers latest arduino keep
downloadtool bossac 1.7.0 arduino keep
downloadtool fwupdater latest arduino keep
downloadtool windows-drivers latest arduino keep
downloadtool bossac 1.7.0 arduino keep
downloadtool fwupdater latest arduino keep
close COM3
downloadtool windows-drivers latest arduino keep
downloadtool bossac 1.7.0 arduino keep
downloadtool fwupdater latest arduino keep
open COM3 9600 timed
send COM3 y
send COM3 9f5c3107-cda9-49ba-b9b0-e98452229e6f
send COM3 2021 2 2 10 31 b421384d6f113f475769f8888a7983a1 5b3e2a6b8ec9b01aa854e6369b8c09f9fce1b980 4c6c0eb2fc85e116e87c0ec941b8e4f30de6e53e7efbc26e299ba1632d7b0a2cf6ae1b9d917bef8609d461f6f0e2da0d2f23964781e4cf7b5c0355d7301c3f4b
close COM3
Closing serial port COM3
Shutting down reader on COM3
Shutting down writer on COM3
writerBuffered just got closed. make sure you make a new one. port:COM3

(I'm assuming the long hex strings are meant to be secrets, but I feel like it should be fine to post them unredacted given they apparently never made it to my board anyway.)

I was able to resolve the issue for myself after some digging around other posts here. The solution was to download the latest nightly build of the Windows Arduino IDE, install the "WiFiNINA" library from the library manager, then use the "WiFi101 / WiFiNINA Firmware Updater" to manually update the firmware of my board by clicking "Open Updater sketch," uploading the sketch to my board, and then selecting "Update Firmware." After the firmware update was complete, my board could be connected normally.

I was originally not sure if these instructions apply since most references to this issue seem to be for other boards, as were the instructions I found elsewhere on the forum. However they appear to work for the Nano 33 IoT as well.

It seems like the firmware update process with the IoT cloud interface is not quite there yet.

Well done - I had exactly the same issue, downloading ther hourly build fixed it. many thanks.

:’( :’( :’(
I have the same problem but also with the FW update I didn’t fix it…
Have someone an idea?

Yo tambien lo actualice y sique con el mismo problema

Hello there,

can you please provide the following info?

  • OS
  • Browser
  • Arduino Board
  • Arduino Create Agent version

Hello @Geo1088
Glad to hear you solved the issue.
It would be a great help for us to better understand exactly what steps did you followed. Did you try to reinstall the Arduino Create Agent? Did you have an old version of the agent installed before?

Hi

I have the same problem. Cannot create a device in IOT cloud. Tried for hours. - Board: Arduino Nano 33 IOT - PC OS: windows 10 (up to date) - Chrome web browser - Agent version: 1.2.1-8d3a8cb

Message: We were not able to configure your device Can't update Firmware: Executing command: exit status 1 Please try to: Restart the Create Plugin on the computer. Reconnect the device to the computer and make sure the power LED lights up.

Digging in some earlier posts, I installed the last create agent version from gitHub, I updated the wifi firmware, I rebooted my PC, I disconnected the board ... nothing seems to help.

Many thanks for helping me out here !

Using a borrowed laptop, I was able to create a device which allowed me to continue working on my original PC (associate thing and device, ...).

Hi, I think we found the issue and we are working to solve it. We think it's related to a whitespace present in your username: for example, my path to my user folder is "C:/Users/Umberto Baldi/" (that space between Umberto and Baldi is the culprit) Could you please confirm the problem is related to the whitespace? Does the user on your pc have the whitespace? And what about the borrowed laptop?

As a workaround, you could update the Nina firmware using the Java IDE.

Hi, should be fixed now, could you please retry?