Can't connect to the Ethernet Shield

I recently bought the Arduino Ethernet shield for my Arduino Uno. Since then I have been trying to connect to the server, with no luck till now. I am trying to access the IP of the shield assigned by the DHCP of my router from within my Local Network, but I'm not able to do so. I even tried reserving a permanent address for the shield, since I intend the shield to be connected to the network at all times. That didn't work as well.

The strange thing is, that when I first connected the ethernet cable and uploaded the basic Web Client program from Ethernet Examples, I could access the server from a different computer connected to my Local Network. But, suddenly after a few seconds, when I refreshed the page, Chrome gave me a "ERR_CONNECTION_REFUSED" error, and after that I haven't been able to connect to the server. After a few retries, when I replaced the network cable connecting the router and the shield, suddenly I could connect to the web server again, but that too for a few brief seconds, then again the same error.

My router TP-LINK Archer C1200 acknowledges the connection to the shield, and the light glows up corresponding to the ethernet port. But strangely again, the device is shown under the wireless clients, when in actuality it is connected with an ethernet wire.

I am very confused by all this, and I'm still trying to connect to the Ethernet Shield server. Please help me sort this out.