Can't connect WiFi shield

hello
I’m having trouble connecting my WiFishield (integrated antenna). Yesterday it worked though …
Trying to run the first sketch on https://www.arduino.cc/en/Guide/ArduinoWiFiShield (code attached), I get this in my serial:

Initializing Wifi…
MAC: 0:0:0:0:0:0
Scanning available networks…
** Scan Networks **
number of available networks:0

Whereas my MAC-address should be 78:C4:E:2:76:13 (I know since yesterday the code did run.).

(I have ubuntu 15.04 and arduino-1.6.5-r5)

Can someone help me?

fagus

wifi_siteCode1_29102015.ino (1.57 KB)

Do you have it connected to a R3 Arduino? No pins overlap? I use a pre-R3 Mega, and it has two pins overlap on each side.

edit: Do you have a SD card in the shield's slot?

I have it connected to a Uno in the same way as yesterday. No pins overlap ...

If it worked yesterday and not today, something has changed. Do you get leds lighting on the shield? It appears it is a hardware failure of some sort, or it would return the mac address. Maybe the SPI bus not working? Nothing else connected to the Uno?

led L9 lights when only the shield is connected to my computer (mini-USB)
no leds lighting when shield is mounted on UNO, except L9 if I press the reset-button ...

I tried yesterday - in vain - to upgrade the firmware ( https://www.arduino.cc/en/Hacking/WiFiShieldFirmwareUpgrading ). But the code to scan the network ran before i tried to upgrade the firmware.

SPI-bus works (tried other code) and I have no SD-cart inserted.