Can't do anything on Mac OS X Big Sur

Hi everyone, I just downloaded the new IDE 2.0, in both standard and Nightly version, but after install I really cannot do a thing. I can only Quit the program, but at the opening I have no window, no active menu... Has someone tried it on Mac Big Sur (I'm currently running Mac Os X 11.2.3)?

1 Like

I'm using Big Sur 11.1 on an M1 Air and the beta IDE seemed OK. Except that I'm now getting Error: Request createNewSketch failed with message: 14 UNAVAILABLE: No connection established when trying to create a new project. And that error has just disappeared. Didn't change any project settings!!! Just retried a few times.

Anyway, the new IDE isn't recognised as an app which will open the .INO files unless you enable the 'all applications' option under the 'right-click' open-with other... dialog. Once in the IDE you can use the File-Open dialog to open any .INO in the project folder which will open the whole project.

I tried opening an existing sketch, but it does nothing: no error or interface. On Catalina works well. I luckily did not updated my wife's MacBook

I’m facing the same problem on Windows 10.

Details below

Computer Specs

  • Manufacturer: Acer
  • Processor: AMD Ryzen 7 3700U with Radeon Vega Mobile Gfx 2.30 GHz
  • RAM: 8GB
  • OS: Windows 10 x64

IDE:

  • Version: 2.0.0-beta.5
  • Date: 2021-04-15T10:44:02.569Z
  • CLI Version: 0.18.1 alpha [b3cf8e19]

Error Message

Error: Request createNewSketch failed with message: 14 UNAVAILABLE: No connection established

When

It happens when trying to create a new sketch

Me too. Same specs.

Same here. MacOS 11.3.1 (Big Sur) on MacBookPro 2015.

Every single version of Arduino IDE 2.0 I've tried (just tried 2.0.0-beta.6) gives the same error and is totally unusable on my Mac.

I've given both "Files an Folders" and "Full Disk Permission" to the "Arduino IDE" application, but no change.

We're discussing @todbot's problem over here:

Most of the functionalities of the IDE 2.0 are implented in the arduino-cli and it comes bundled with it, to do this we start the CLI in daemon mode and start a local webserver on a certain port, if there is a conflict with another process that's already running the CLI cannot be started.

Could you please show me the output of these commands?

If you're on OS X: sudo lsof | grep localhost.
Windows: netstat -ab, you'll need to run a Command Prompt with administrative rights.

Also the content of the arduino-cli.yaml file would be great, on OS X it's in /Users/<your_username>/.arduinoIDE/arduino-cli.yaml, on Windows should be C:\Users\<your_username>\.arduinoIDE\arduino-cli.yaml, not exactly sure about the last one.