Cant find binary files for NON-OTA Firmware

i am using nodemcu and wants to use AT commands so downloading the NON OTA Firmware in it . But i cant find the eagle.flash.bin and eagle.irom0text.bin files in the sdk folder of the esp8266 which i download from this link GitHub - espressif/ESP8266_NONOS_SDK: ESP8266 nonOS SDK
.
hoping to get the reply as early

Also one more query

  1. In the functional block diagram of the esp8266 the yellow colour FLASH block …it is the external Spi flash/ programmable ROM ???.
  2. Also in the CPU topic in the datasheet it is written that CPU is interfaced with
    • Programmable RAM/ROM interfaces (iBus), which can be connected with memory
    controller, and can also be used to visit flash.
    • Data RAM interface (dBus), which can connected with memory controller.
    hoping to get the reply as early

Now here if i see the block diagram so is my data RAM and programmable RAM both are same that is SRAM or they are different ??? If different then where are they in the block diagram

  1. when we download firmware in the esp8266 different address are given for downloading the binary files in THE FLASH MEMORY of the esp8266.
    As we know CPU interracts with only RAM OR Processor register …so after downloading the firmware in the Flash memory which is external spi flash the data is send to SRAM or processor register???

https://www.espressif.com/en/support/download/at?keys=&field_type_tid[]=14

the common code is executed directly from external flash

https://www.esp8266.com/wiki/doku.php

On the file downloaded from the given link i didn't find the eagle.flash .bin and its other companion.
Is the name changed for these two files?

guptakunal:
On the file downloaded from the given link i didn't find the eagle.flash .bin and its other companion.
Is the name changed for these two files?

eagle.flash .bin is usually not used with AT firmware upload.
it is used only for NON-BOOT MODE, whatever it means

So for AT commands over non OTA ..i Don't have to upload eagle files and just then only 3 files .?

the AT commands reference has flashing instructions for different flash sizes.
or wit the AT firmware download there is README.md in bin/at folder.
for example

### Flash size 16Mbit: 512KB+512KB
   boot_v1.2+.bin              0x00000
   user1.1024.new.2.bin        0x01000
   esp_init_data_default.bin   0x1fc000 (optional)
   blank.bin                   0x7e000 & 0x1fe000

these are the pics of the datasheet of esp8266 which shows the addresses at which files to be downloaded in serial flash for NON OTA and OTA firmware .


and this is the pic which shows the files that had to be downloaded for OTA and NON OTA firmware.
now here what u are recommending is for BOOT and NON boot modes . So are these same as OTA and NON ota

ota and not ota is only about space for ota remaining on flash

Well i got the one step ahead,
Their are two things now

  1. i download the bin files from the official NON OS SDK for my esp8266 with spi flash of 4096kb by ESP Flash Download Tool . my firmware gets downloaded with showing my MAC address on the flash tool,but now when i test AT commands ...they dont work .dont know why ,no error is shown on the command line of esp flash tool but AT commands also dont work. SO what are reasons for that? i also chose the correct address for my bin files and everything goes fine but AT commands dont run. Cant figure out what is error, So anykind of help will be very greatfull

  2. Another thing on lots of surfing on net i found one link ,in this i directly download this bin file at the 0x00000 address using Nodemcu_ flasher
    by this way my firmware gets downloaded and also AT commands are also running and on checking the firmware this version is downloaded , Now i want the latest AT firmware so i use cloud update using the AT commands. BUt on doing so i get the output as this .

And after that i run the AT commands , they now dont run . So in short as an alternative to first point , i download the older version of AT commands and connects with wifi and do cloud update and but then AT commands dont work.

So what can be reason or what is error. My main concern is to get the latest AT firmware in my esp8266 But i tried these two ways and not happening from any way out . So please reply and any help will be very helpfull

set the line end in Serial Monitor to "Both"

i didnt get that ...can u explain in detail.

i am working on this thing from about 1-2 weeks so kindly provide your suggestions on this ... really want to do this thing but always gets struck