Cant find serial port for Mac

I am new to arduinos. In order to begin learning and using the tech I bought a starter set from smraza off of amazon. The starter kit included an arduino uno r3. the arduino has ATMEGA328P-PU and a MEGA16U2 serial port chip.

I am running the arduino IED using mac OS X el capitan. I have tried to research if I need any drivers for the arduino but all that I have found pertain to other serial port chips. As so far, I have not read anything relating to the MEGA16u2. When I have the arduino plugged in the only port that is displayed is /dev/cu.Bluetooth-Incoming-Port.

Has anyone come across this problem with this arduino and solved it? Or, is this just another should have gotten a windows moment.

Thanks in advance.

I have also come across this problem and thought that I should try it out on Windows but the result was not really nice. It kept on saying 'SERIAL PORT NOT FOUND' now I am fed up of this.
Any help will be Appreciated.
Thanks to all in advance.

I tried using my girlfriends windows 10. There wasn't even an option for a serial port. At that point I was fed up and uninstalled the IED from her computer before she saw that I had downloaded it. I am assuming that I needed a driver for the windows but was unable to find which driver that I needed.

To end this unresponsive post I found my simple solution. Buy a genuine Arduino. NOT A CLONE! do not buy from smraza on Amazon.