cant find TFT library (yx32b),(SSD1289)

i bought this TFT screen but i have no idea how to run it
i've tried libraries and i have no idea how to connect it to an arduino UNO or a MEGA
this is the product
3-2-TFT-320-x-240-LCD-Display-Module-with-Touch-Panel-PCB-Adapter
any help :frowning:

You need to use the UTFT and UTouch libraries.
http://www.henningkarlsen.com/electronics/library.php

You may/will also need an adapter board for either an UNO or Mega/Due. for you might not be able to just connect the display directly to the Mega/Due.

You need a general purpose LCD shield..

The display looks like the sainsmart and they also have the shield.

Google search for Sainsmart.

No no not sainsmart, simular to a sainsmart shield but not sainsmart. The quality is not so good.

But will the saoinsmart shield connect it ?

yes

http://www.elecfreaks.com/store/lcd-tft01-arduino-mega-shield-v20-shd10-p-214.html
i have already this shield will it work ???

That should work, yes.

really ??
how should i connect it ?
the screen is 32 pins
and shield is 40

Perhaps this one will be better suited for your display.
http://www.ebay.com/itm/TFT-SD-Shield-for-Arduino-DUE-TFT-LCD-Module-SD-Card-Adapter-2-8-3-2-inch-Mega-/121057447668?pt=LH_DefaultDomain_0&hash=item1c2f960ef4

cant i simply try to connect it
the problem is i live in Israel and it takes about 45 days of shipping
so i’ll put that as the last hope

Sure you can try if you have 32 male to female jumper wires and the shields pin layout

ummmmm i do have but can you help me with the pin layout please ?

update:


i used this and not working :confused:
the led worked and the screen lighted up
but no display
i didnt connect db1 db3 db5 db7 db9 db11 db13 and db15
is that it i'll connect them as fast as i can

Yes, you need to connect those pins because they are your data bus lines.
Make sure you are connecting them in the right spots.

got the main screen working but the touch isnt working
i am thinking about making a pcb from 40 to 32 pins

What pins did you put for the UTouch constructor? It should be something like this.
UTouch myTouch(6,5,4,3,2);

it's exactly as you said
but not working i'am thinking about returning it i got it for 25$
and the shield for 10
it looks like overpriced to me :confused:

Double check your wiring and if it still doesn't work, then get a new one.

i double checked the wiring and even soldered them
the screen works
but no touch
btw i didn't connect
the extra pins from 40 to 32 there are almost 5 pins
such as
TP_clk
TP_in
tp_busy
tp_out
where do i connect them ??
they are on the shield but not on the screen