can't find the right battery

Hi,

i made a robot based on teh arduino pro mini i used : - bluetooth hc5 module - L9110S Module L9110 DC H Bridge - 2 dc motors - 1 servo - Ultrasonic Module HC-SR04 - HMC5883L temperature compensation triaxial compass

i use this chassis : https://www.aliexpress.com/item/Light-Damping-balance-Tank-Robot-Chassis-Platform-DIY-suspension-tank-shock-absorption-SN800/32472090186.html?spm=2114.01010208.3.195.Efwl4l&ws_ab_test=searchweb0_0,searchweb201602_1_116_10065_117_10068_114_115_113_10084_10083_10080_10082_10081_10060_10061_10062_10056_10055_10037_10054_10033_10059_10099_10078_10079_10077_426_10073_10102_10096_10052_425_10050_10051,searchweb201603_2&btsid=f75acab3-c395-480c-8aa4-afba44bd03cc

now my problem is that i can't find any battery that can power this robot , i tryed with 4 AA and a power bank of 10000 mAh and 1amps but it didn't provide enough power.

can you help me please

What do you mean by "not enough power"?

The H-bridge may not be able to handle the current requirements of the motors. What is the winding resistance?

i mean that the robot can barely go forward , i am using two 5 v brushed DC Motors that came with the chassis , i have a L298N driver but it didn't work it's even worse than the h bridge

The L298N [u]is[/u] an H-bridge, but it drops 2-4 V internally so it is a bad choice for low voltage motors.

Try a modern motor driver like this one: https://www.pololu.com/product/2135

is there an alternative , it's a school project and i need it next week

Have you size up the motor torque value?
The motor torque may be not enough to lift the weight of your entire robot.

connect the battery directly to the motor, will it go forward? if not, then the motor torque may be not enough to lift the weight of your entire robot.

i try to connect one motor directly to the battery and i worked , but when i connect the two motors they they slow down and barely go forward .

Sounds like you need a battery that can supply the current needed. You could use a few lithium batteries or parallel more aa batteries.

SoufianeSqalli: i try to connect one motor directly to the battery and i worked , but when i connect the two motors they they slow down and barely go forward .

Are you connected the 6V 4 AA battery for this? then the motor torque may be not enough to lift the weight of your entire robot. How much weight for your entire robot?

Try to use 6 AA 9V battery, connected to two motors and try again.