Cant fix upload to i/o error

Hi everybody,

I,m having so much trouble :'( trying to get this arduino board to work and I would appreciate any help I can get. I have searched and read similar responses on how to fix this error "programmer is not responding" when i upload a sketch. I am using windows, serial ports available are comm1 (error "programmer is not responding"), comm3 (i get this error "[VP 1] device is not responding correctly) , and comm4 (error "programmer is not responding")...I am using arduino version 007, i,ve uninstalled and reinstalled but to no avail. I just want to see that little red led blink :-/

I,m an ardunio novice so I welcome any instructions that may help me to solve this error.

Check your Device Manager (in Control Panels > System > Hardware, I think) to see which com port you should be using. The Arduino will show up as a "USB-Serial Device" under Ports (COM & LPT) or something similar.

There are some general uploading troubleshooting tips at: http://www.arduino.cc/en/Guide/Troubleshooting#upload. Give them a shot and see if any of those help.

I tried connecting the arduino board to my friends laptop and it worked so must be my laptop :-?...is the arduino board ment to do anything once the sketch is uploaded to it? coz i would assume an led would at least blink but nada! any ideas guys?

hi

did you remember to install the FTDI USB drivers?

D

Which sketch did you upload?

Some of the boards have an on-board LED connected to pin 13, some don't. If you uploaded a sketch that should blink an LED and nothing happens, try connecting putting an LED on pin 13 (the longer leg goes in pin 13, the shorter leg goes in the ground pin).

hi mellis,

I uploaded the led_blink sketch...and yep i have a lovely red LED sticking in pin 13 and into the grnd slot but still nothing happens..i.m trying eveything to figure it out...i so want this board to work

yeahhhh..i got the arduino board to work! thank goodness, was ready to have a nervous breakdown!...ok so this might have been obvious to others but if any one else has this problem of "programmer is not responding", this might help....i went into my device manager to check out which port was exaclty using the arduino (comm4) and made sure that underneath the board on the black chip either reads two values, select the correct microcontroller for the compilation, mine was ATMEGA168. ok when all that matches up with the settings in the arduino program, compile - reset - upload to arduino but with mine i pressed the reset button for 5 seconds and uploaded the code then straight away and it worked!!! i think that what was giving me the error (waiting to long to upload? didn,t know seconds were long)..i tested other sketches and it works beautifully!! ;D thanks for everybodys help and suggestions.

happy arduino-ing!

sillyrabbit ;)

I have assembled arduino board. And burned the bootloader using parallel cable. After that LED connected to pin13 flashig. I tried uploading the sketch to board using com1 cross cable and upload is failed giving the following error.

Error inside Serial.()
gnu.io.UnsupportedCommOperationException: Invalid Parameter
at gnu.io.RXTXPort.setSerialPortParams(RXTXPort.java:171)
at processing.app.Serial.(Serial.java:130)
at processing.app.Serial.(Serial.java:72)
at processing.app.Uploader.uisp(Uploader.java:156)
at processing.app.Uploader.uploadUsingPreferences(Uploader.java:78)
at processing.app.Sketch.upload(Sketch.java:1693)
at processing.app.Sketch.exportApplet(Sketch.java:1755)
at processing.app.Editor$40.run(Editor.java:1892)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)
Error: Permission denied
→ /dev/com1

please help me

Are you using a serial port? Or USB with an FTDI chip and the FTDI drivers? Or something else?

thanks for the reply. I have assembled arduino board (from Board_toproduce.PDF) with RS232 and ATMEGA8 chip I am using serial port(com1) with a cross cable for uploading from a Windows-XP machine using Arduino-0007.

Sridhar

I have assembled arduino board (from Board_toproduce.PDF) with RS232 and ATMEGA8 chip I am using serial port(com1) with a cross cable

Not sure what "Board_toproduce.PDF" looks like, but if it's a standard serial Arduino, you need a straight cable, not a cross (I assume you mean null modem) cable.

-j

Yes it is a stndard serial Arduino board. I tried both the serial cables (straigt and cross) with Baud rates 9600 and 19200 but the resonse is same. Can I test the board using Hyperterminal by any chance. Please help.

Thanks in advance. Sridhar

OK, re-reading your first post leads me to think you may not be sure which com port to use. If your laptop has a modem, most likely com1 is the modem, so you definitely don’t want to use it.

To make sure you are using the correct com port, connect to that port with hyperterminal and do a loopback test - short pins 2 and 3 together using a wire (or key, paperclip, pocketknife, screwdriver,…). Type in the hyperterm window; the characters you type will go out the TX line and back in the RX line via the loopback you made shorting pins 2 & 3. Port speed, parity, and stop bits don’t matter for this test, but flow control should be off (none).

If you can’t get the characters you type to echo back to you, there is a very good chance there’s a problem with the port (hardware, driver, etc), or you are on the wrong port.

-j

thanks for the reply. Finally I could trace the problem. I have used a Right angle male connector in place R/A female D-sub connector. I have replaced the same with R/A female and the board started working. So its a question of gender. Any how my sincere thanks to Mellis and KG4WSV for their efforts in guiding me.

Regards. Sridhar

Sorry, I don't know what the interface to the bootloader looks like if you try to talk to it via hyperterm.

Is anything else trying to use the com port? e.g., if you've got it open with hyperterm, Arduino can't use it. Sorry, I don't do windows, so I can't offer a lot of help here.

-j