Can't get Arduino software installed

I just received the Arduino Diecimilla Plus USB board that I purchased from Make magazine. I am trying to install the software I downloaded (arduino-0011-win.zip) on my Windows XP SP3 machine. After unzipping the file mentioned above, I double-clicked on the arduino.exe file. First, I got an Open File - Security Warning dialog box asking me if it was OK to run arduino.exe. I selected run and a second Open File - Security Warning dialog box opened and asked me if it was OK to run the javaw.exe file. When I selected run, a Java Virtual Machine Launcher dialog opened with a fatal saying it could not find the Java 2 Runtime Environment. I went to the Sun website and downloaded the latest Java RTE (Version 6, Update 5). The install was successful and Java Web Start works properly. Unfortunately, when I reran arduino.exe after a reboot, I still got the same error message. How do I get the arduino install software to recognize the presence of the Java RTE? Another question I just thought of; Do I literally have to install Java 2 or will the newest version be backward compatable? If the tools are version locked, what exact version of Java is required and where do I find it? Any help would be appreciated since I seem to be stuck at square 1. Thanks Jim

You could using the run.bat file instead of arduino.exe. Or, if you delete the java directory in the Arduino application directory, it should (I think) use the java you installed. If that doesn't work, try editing run.bat to point to that java.

Maybe I need to step back and give you more detail. 1.) I downloaded arduino-0011-win.zip 2.) I extracted the contents to a temporary folder 3.) I could not find a setup file that would actually do the installation of the arduino tools, create the proper folders under Program Files, etc. In other words, there is no Arduino application directory. From within the temporary folder, I tried to run arduino.exe, thinking this file might actually do the instillation.

It is at this point that I get the error message about no Java 2 RTE. If the assumption that running arduino.exe installs the software is incorrect, how do I install the software from the temp folder?

The run.bat file in the temp folder points to files and folders that do not exist in the Java file structure (as installed from the Java website). Since the Arduino software isn't really installed, there is no Arduino file structure and hence, no Java subfolders.

I found my problem! I had neglected th check the “Use Folder Names” box in WinZip. All of the files went into a single folder instead of recreating the Arduino file structure. Works now - thanks for your help.