Cant Get Compiler to Complete 0022 OSX 10.6.7

Hi all, sorry for the noob question..
I just installed 0022 on my MacBook Pro. When i try to compile the Example 'Blink' i get the following:

/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/bin/avr-g++: line 6: /../avr-4/bin/g++: No such file or directory
/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/bin/avr-g++: line 6: exec: /../avr-4/bin/g++: cannot execute: No such file or directory
/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/bin/avr-g++ returned 126

My avr-g++ is installed in: /Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/bin so i am not sure why it can't find it??

Any help would be greatly appreciated!!

Anybody ever seen this or have any ideas for me??

Hi,

I was having a few problems when I had sketches in folders with spaces in the names of them. I see you have a folder with a stop in the name "Arduino.app" perhaps this is causing a problem. Try changing the folder name to have an underscore and not a stop in it like this "Arduino_app".

This may work for you.

Cheers Pete.

Thanks Pete,
The Arduino.app is not a folder but the application package itself?? At least that is my take after digging a lil in Finder.
Not sure if the application package will work if i loose the .app???

Anybody can confirm or deny this??

Thanks Again

What I would do is drag the whole app from your Applications directory to the trash.

Reload 0022 and let it install to where it want to install it to.

You should find that Arduino.app will reside back in the Applications folder and it should create a save folder in your Documents/Arduino folder.

As this program is so small and simple, reloading it isn't really a problem. You will not lose anything you have samed if it has saved it to the Users/Documents/Arduino folder

Cheers,

Sugar

gruv2ths:
The Arduino.app is not a folder but the application package itself??

Aghh i though you said that it was in the folder

My avr-g++ is installed in: /Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/bin

Am i misunderstanding the installation location here ...

Cheers Pete.

"Arduino.app" perhaps this is causing a problem.

That has nothing to do with the issue. The ".app" extension tells the filesystem that a folder is an Application Bundle. Right-clicking on an application and selecting "Show Package Contents" will show everything inside of the Bundle.

My avr-g++ is installed in...

Is the user you are running, running as an Administrator?

It is possible your installation got corrupted. Try deleting your download, drag the existing app the trash, re-downloading, and re-"installing". Just for grins, you might move the Arduino application to another folder (like the Desktop) and see if it will run correctly from there.

I just realised that this is NOT a windows installation .... please erase EVERYTHING I have misled you with from your memories :blush:

Pete.

Hey Guys,
Thanks for the input..
So i re-downloaded and tried to install (by copying the Arduino.app) in the root hard drive directory, in applications and even the desktop. Whenever i do the same file seems to be problematic. The only thing that changes in the error is the path depending on where it was installed. I know that the Arduino doesn't like a path where there are any spaces. My hard drive is called "Macintosh HD", I am afraid to remove the space, as the OS is installed on that drive. In my recent past life i was a Windows guy and doing something like removing a space in the name of the hard drive would cause certain disaster..

The space in the volume name doesn't matter. The file system is relative to root (/), not the volume's name. Changing the volume name usually doesn't break things since programs since it gets mounted to an alias anyway.

Regardless, mine is named "Core Memory", so it is unlikely to be related to spaces.

Again, are you running this user as a administrator or regular user?

Yes, my user is administrator.

So does anybody else have this g++ file problem??
Is this a Unix problem that may be troubleshoot in Terminal?

Or can anyone refer me to someone who can help??

Thanks, i appreciate all the help so far!!

For more troubleshooting ideas, try downloading 0018 and see if it works. Don't even drag the file out of the disk image, just run it from there. If 0018 works, move up one at a time until you get the errors again.

Don't worry about compiling for the correct board, just see if you can get past the complier errors.

Tried i few different versions and ran them from the archive and even from a bunch of different locations, always the same g++ file fail.
Took it to the Genius Bar last night hoping those guys might be able to help me. No dice.
Ran the compiler perfectly on a Mac Mini at the Apple store which was disturbing… :frowning:

Based on all of the above..............
I would think that this is not an Arduino issue. It would more than likely be an OSX issue where you have either a corrupt or missing file within the OSX that Arduino is looking for.

Do you have another Apple or a mate with one to try it on? I bet 2cents Aust it works.

  1. If you drop into terminal what do you see with this:
ls -l /Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/bin

(Assuming Arduino is in the Applications folder.)

  1. Do you have Xcode installed? (If so, what version)

  2. Create a new user account (Administrator or Regular) and see if you have the same problem. (This will tell if there is a problem with OSX or if there is a problem with your particular user account.)

Sugar,
I am sure you are right. I have run the Arduimno software on other Macs and it was no problem. It has to be my machine, just not sure how to fix it..

-Stephen

James,

  1. If i put that code into terminal i get the following:

total 58784
-rwxr-xr-x 1 gruv2ths admin 1293348 Dec 24 13:56 avarice
-rwxr-xr-x 1 gruv2ths admin 1043968 Dec 24 13:55 avr-addr2line
-rwxr-xr-x 1 gruv2ths admin 1085208 Dec 24 13:55 avr-ar
-rwxr-xr-x 1 gruv2ths admin 1445760 Dec 24 13:55 avr-as
-rwxr-xr-x 1 gruv2ths admin 209 Dec 24 13:55 avr-c++
-rwxr-xr-x 1 gruv2ths admin 1043980 Dec 24 13:55 avr-c++filt
-rwxr-xr-x 1 gruv2ths admin 209 Dec 24 13:56 avr-cpp
-rwxr-xr-x 1 gruv2ths admin 209 Dec 24 13:55 avr-g++
-rwxr-xr-x 1 gruv2ths admin 209 Dec 24 13:55 avr-gcc
-rwxr-xr-x 1 gruv2ths admin 195116 Dec 24 13:56 avr-gcc-3.4.6
-rwxr-xr-x 1 gruv2ths admin 404576 Dec 24 13:56 avr-gcc-4.3.2
-rwxr-xr-x 1 gruv2ths admin 401 Dec 24 13:56 avr-gcc-select
-rwxr-xr-x 1 gruv2ths admin 215 Dec 24 13:55 avr-gccbug
-rwxr-xr-x 1 gruv2ths admin 211 Dec 24 13:55 avr-gcov
-rwxr-xr-x 1 gruv2ths admin 4957872 Dec 24 13:55 avr-gdb
-rwxr-xr-x 1 gruv2ths admin 4957872 Dec 24 13:56 avr-gdbtui
-rwxr-xr-x 1 gruv2ths admin 1175204 Dec 24 13:55 avr-gprof
-rwxr-xr-x 1 gruv2ths admin 58 Dec 24 13:55 avr-help
-rwxr-xr-x 1 gruv2ths admin 53 Dec 24 13:55 avr-info
-rwxr-xr-x 1 gruv2ths admin 1822508 Dec 24 13:55 avr-ld
-rwxr-xr-x 1 gruv2ths admin 51 Dec 24 13:55 avr-man
-rwxr-xr-x 1 gruv2ths admin 1064452 Dec 24 13:55 avr-nm
-rwxr-xr-x 1 gruv2ths admin 1388288 Dec 24 13:55 avr-objcopy
-rwxr-xr-x 1 gruv2ths admin 1523416 Dec 24 13:56 avr-objdump
-rwxr-xr-x 1 gruv2ths admin 709 Dec 24 13:55 avr-project
-rwxr-xr-x 1 gruv2ths admin 1085208 Dec 24 13:55 avr-ranlib
-rwxr-xr-x 1 gruv2ths admin 580272 Dec 24 13:55 avr-readelf
-rwxr-xr-x 1 gruv2ths admin 1052160 Dec 24 13:55 avr-size
-rwxr-xr-x 1 gruv2ths admin 1044000 Dec 24 13:55 avr-strings
-rwxr-xr-x 1 gruv2ths admin 1388288 Dec 24 13:56 avr-strip
-rwxr-xr-x 1 gruv2ths admin 671000 Dec 24 13:55 avrdude
-rwxr-xr-x 1 gruv2ths admin 1074 Dec 24 13:56 ice-gdb
-rwxr-xr-x 1 gruv2ths admin 51 Dec 24 13:55 ice-insight
-rwxr-xr-x 1 gruv2ths admin 264 Dec 24 13:56 kill-avarice
-rwxr-xr-x 1 gruv2ths admin 1345 Dec 24 13:56 libusb-config
-rwxr-xr-x 1 gruv2ths admin 344092 Dec 24 13:56 make
-rwxr-xr-x 1 gruv2ths admin 305720 Dec 24 13:55 simulavr
-rwxr-xr-x 1 gruv2ths admin 59800 Dec 24 13:55 simulavr-disp
-rwxr-xr-x 1 gruv2ths admin 75992 Dec 24 13:55 simulavr-vcd
-rwxr-xr-x 1 gruv2ths admin 225 Dec 24 13:55 start-avarice

  1. I have the latest and greatest iOS SDK installed and it came with Xcode 3.2.6
  2. the guy at the genius bar tried making a guest account then running Arduino and the same failure occurred.

Thanks again for all the help guys, hope we can get this fixed..

  1. I have the latest and greatest iOS SDK installed and it came with Xcode 3.2.6

The latest and greatest ships with Xcode 4.x. iOS 4.x ships with 4.0 while iOS 5.0 ships with 4.2.

Xcode is my only other thought at this point. For some reason the Arduino environment is not seeing the path to the correct copy of gcc. (Arduino ships with GCC for ATmega, while Xcode contains GCC for Cocoa/iOS.)

For what it is worth (which is probably not worth much to you if yours isn't working grin), I have Arduino 0022 and Xcode 4.2 with no problems compiling.

Okay, one more idea.

If you run "java -version" on the command line, what do you get back? I get:

James-MBP2b:~ james$ java -version
java version "1.6.0_24"
Java(TM) SE Runtime Environment (build 1.6.0_24-b07-334-10M3326)
Java HotSpot(TM) 64-Bit Server VM (build 19.1-b02-334, mixed mode)