Can't get Debian to connect

Hey guys,

I have an Arduino Uno and I'm using the latest version of Debian as an environment. I can't see to get it to connect to the Serial port however. I have everything connected, I have the IDE (1.0.3) set to Arduino Uno as the board and when I click Serial Port my only option is /dev/ttyS0. I have the user in dialout and uucc and whatever else I've seen but I cannot get it. It just fails to upload and when I shift click on upload it says it couldn't find the USB device.

Any ideas?

can you use it as su?

what about the read/write permissions of the port itself

Osgeld: can you use it as su?

what about the read/write permissions of the port itself

That's the most disturbing part, I meant to mention it. If I open it as root, it doesn't work still.

Any ideas from anyone else? I'm at a loss here!

I am having the same issues as skylerl. I was able to use the board previously, but now I cannot; I am not sure what changed. I am running on a Debian based system (Mepis 12), 64 bit.

When I plug the board in (Uno), I can see ttyACM0 in /dev, and dmesg reports:

[ 108.286268] usb 7-1: Manufacturer: Arduino (
[ 108.286272] usb 7-1: SerialNumber: A4132373935351817271
[ 108.361005] cdc_acm 7-1:1.0: ttyACM0: USB ACM device
[ 108.364265] usbcore: registered new interface driver cdc_acm
[ 108.364271] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters

and when the board is not plugged in, ttyACM0 is not in /dev. There is no file in /dev/lock/. I have put /dev/ttyACM0 in the preferences.txt file in .arduino/ and the serial.debug_rate=9600.

Running as root makes no difference.

I will note that I was experimenting with serial communications with an Android device using Java, and the instructions lead me to install librxtx-java, but I have since removed that package. Also, when I run the arduino IDE from the command line I get:
Experimental: JNI_OnLoad called.
Stable Library

Native lib Version = RXTX-2.1-7
Java lib Version = RXTX-2.1-7

so I don’t think there is a conflict there (I read about that somewhere in my search for a solution). The board is fine, because I was able to upload a sketch to it using a Windows computer at work. I have searched the Internet for hours and tried everything except for reflashing (is that the correct term, so much of this information is now a blur and possible solutions are mixing in my mind) the arduino board.

I don’t know what else to use for search terms, and would really appreciate any advice the experts out there may have.


I have an update to my little issue, unfortunately, not a solution. I was able to upload to the Arduino using another computer running Windows, so there is nothing wrong with the board.

Here is a description of my longshot experiment. I have VirtualBox installed with a Windows 7 guest on the same Debian based computer that won’t recognize the Arduino. I downloaded the Arduino IDE and installed the Uno driver in the Windows 7 guest (and the necessary guest additions for VirtualBox to get the USB port to work in the guest). I typed in a short blinking LED sketch and was able to upload it to the Uno without any issues at all.

Does this mean there is some type of bug in the IDE software? Does anyone have any idea what could the wrong? Is there someplace else I should be posting to help with this problem?

Thank you for any input anyone may have.