Can't get drivers to work to connect Duemilanove to Windows 7

Hey so I'm really new to this whole thing. I got lent an Arduino Duemilanove to try out. I followed the instructions on the installation page on the main Arduino site. I downloaded the Arduino environment and then plugged in the board. I went into device manager to update drivers manually but windows says it can't find it even though I point it to the Arduino subfolder called 'drivers.' Then I checked online for a solution and found out that I needed to get a FTDI device driver for Windows 7 in order to get the Arduino going. So I went to the ftdichip website and downloaded the driver and tried to update drivers again in device manager. This time it said that it updated successfully. BUT when I open up Arduino I'm supposed to choose the board model under the 'tools' menu (which I was able to do fine) and then I'm supposed to choose my serial port except the 'serial port' option in the menu is greyed out. GAH! I'm trying out the Arduino for a university assignment and time is short so this is stressing me out that I can't even get the flipping thing started! Help would be much appreciated.

Check windows control panel, device manager, ports. Do you see com-ports when arduino is NOT connected? And when you CONNECT it, do you see more com-ports?

Cheers, Kari

There's a list of devices that and when I plug in the Arduino it shows up as usb serial port. Is that what you're asking? Sorry if I come across as ignorant! I'm new to this.

Does the USB serial port have a number? Check the the properties for that port and see the driver version, mine shows FTDI. 2.8.2.0. If I correctly recall, that was found in "\drivers\FTDI USB Drivers"-folder inside the arduino IDE.

Did you try that on the IDE? It should be the one.

Cheers, Kari

Yeah i tried pointing it to that folder but it says it can’t find the drivers. ><

DONT WORRY! PROBLEM SOLVED! I just tried pointing it to the FTDI drivers again. And it worked. Thanks for the help!