Can't get multiple wheels to move with DFRobot

Hey. I have a probleme making a robot work with my netduino, I know this is an Arduino forum, but as far as I understand, it's pretty much the same. I think you guys might know what is my problem...

So I ordered a DF Robot kit and got some help to put it together.

I want to control the wheels with my netduino.

What I want to do is simple. Press the netduino's button, and start the 4 wheels in the same direction, full power.

When I try to make it run with one wheel pluged in my breadboard, it works, the wheel move.

But when I add a second wheel, nothing appens. It seems that I dont have enough power to make the wheels move.

The netduino is powered by a 9volt battery. When I press the button, the net duino let the big power source ( 5 AA batteries , as suggested in the kit) flow in the motors. (this is how I see it correct me if i'm wrong.)

Here's a scheme that my friend made me back when I was playing around before I had this kit. ( note that I removed the resistor)

Basically, I'm doing the exact same thing with my df robot kit.

The motors negative wires are all lined up in the #5 pin of the 4n35 transistor. The 4 positive wires are all lined up with the positive power source positive wire. (5 new AA batteries)

I'm using the 4n35 transistor that came with my netduino kit I ordered.

I'm starting to realise that I will need a motor shield. Which one do you guys suggest ?

But before I go on and buy another thing, is there a way to get it working with my current setup ?

Thanks, Dave

I know this is an Arduino forum, but as far as I understand, it's pretty much the same.

Same general shape. Same general layout. That is a far as the similarities go.

PaulS:

I know this is an Arduino forum, but as far as I understand, it's pretty much the same.

Same general shape. Same general layout. That is a far as the similarities go.

yeah.... I figured i'd get some hate.

I guess I should have lied and said I was using an arduino kit. 8)

I think my problem is on the circuit part...

I thought you guys could help me with that.

Why aren't you asking on the netduino forum?

yo whats up men. why do you snob people like this. of course I asked the netduino forum. the community is smaller and I'm looking everywhere... you know... im trying to... learn...shame on me I guess. jesus christ man calm the fuck down.

edit: so i guess... this is going nowhere .... walks away with his microsoft toy, some people pointing at him while whispering to their peers.... other people loudly booing him and yelling insults....

I was about to suggest a motor driver but then I read your last post and don't feel inclined to help somebody like you…

Hey whats up drew. I was just being an asshole to and asshole... Judging by his attitude and a few posts hes made this week, I think he has a thick skin and he should be ok... im actually a pretty easy going guy.

PaulS is a little tough on noobees, especially if they ask about non-Arduino stuff, but so am I too, ;-). For myself, I have a NetduinoPlus, but could never get the ethernet stuff to work properly, so I abandoned it in favor of regular Arduino Ethernet boards. Bummer.

Re your robot, forget the motor driver kluges, and just buy a motor shield like the following, http://www.adafruit.com/products/81

The L293D chip has 4 h-bridges for your 4 motors, and probably provides enough current for the motors used on the DFRobot base. If not, you can plug a TI SN754410 chip in place of the L293D, http://www.jameco.com/webapp/wcs/stores/servlet/Product_10001_10001_1054684_-1

Good Luck.

Probably the easiest thing to do is get a dual h-bridge setup like below to control the motors.

http://www.ebay.com/itm/Dual-H-Bridge-DC-Stepper-Motor-Drive-Controller-Board-Module-Arduino-L298N-236-/360666665494?pt=LH_DefaultDomain_2&hash=item53f9689216

zoomkat: Probably the easiest thing to do is get a dual h-bridge setup like below to control the motors.

http://www.ebay.com/itm/Dual-H-Bridge-DC-Stepper-Motor-Drive-Controller-Board-Module-Arduino-L298N-236-/360666665494?pt=LH_DefaultDomain_2&hash=item53f9689216

He's got a 4WD, but might be possible to wire the 2 motors on a side together, or buy 2 of those.