Can't Get Program to update on Arduino BT...

Okay so this is bizarre… I’ve selected the right serial port, right microcontroller, IDE tells me that my program uploaded fine… but its not working. I just tested my computer setup with another board (an NG) and it accepts led_blink just fine.

all that happens on the BT is that pin 13 flashes an LED at about 200ms intervals. I think this was actually the last program i put on the board (to test it after i got it in the mail)… so it did work at one point (I was using one 1.5V AA battery then i think). Now I’m using 2 AAs, the 3V3 light turns on.

All I’m trying to do at this point is get another pin to flash an LED (or at least change the interval on the pin 13 one… anything!)

occasionally earlier i was getting this:
Error inside Serial.()
gnu.io.PortInUseException: Unknown Application
at gnu.io.CommPortIdentifier.open(CommPortIdentifier.java:354)
at processing.app.Serial.(Serial.java:127)
at processing.app.Serial.(Serial.java:72)

but i restarted a few times and messed around and it seemed to go away.

I’m on Mac OS X 10.4.9

I’ve tried:
-putting in fresh batteries (current ones are brand new… my multimeter reads 3.15V off them)
-putting pin 7 high, low

  • putting 10K to ground from Rx
    -jumping Rx and Tx (read to try that somewhere, but it made the board go even weirder)
    -upgraded to 0007 from 0006
    -copied the macosx_setup.command file from Processing 124 (since it was the only one i could find) and then restarted
    -at one point i tried sticking LEDs to ground from Rx and Tx… they were solidly lit up, as soon as i turned on the power

things ive read but didn’t understand:
-clean out /var/spool/uudp or something? couldn’t find that dir in spotlight or in the terminal

… now the IDE is hanging when i click export… ayiyiy!

so give it to me straight… is arduino bt incompadible with some new java update or something? is my chip fried? is there a way to test that?

thanks so much.

im gonna go try weeping like a little girl, see if that helps.

i still love arduino.

C

hi

it sounds like you are close to having it working… I just taught a class where 50 students used BT modules, and by far the only real problem is in getting the serial port set up correctly on the host machine. Once that is done they work really well.

A few things you mention are not a good idea:

  • connecting something to pin 7 ( this is the BlueGiga reset pin. Leave the resets to the Atmega :slight_smile: )
  • connecting RX and TX together ( this just bypasses the Atmega chip, leaving the BlueGiga to work on its own. This won’t help, as you need the Arduino code on the Atmega to make it communicate properly.)
  • Leds from RX and TX (without resistors) to ground could damage the Bluegiga and/or Atmega 168.

Are you using 115200 as the serial speed, and have you selected Atmega 168 as the chip to program?

Bear in mind that the Arduino IDE and the host computer will hang during the upload process if the BT module is powered off.

Keep trying, it sounds like you are very close to having it working.

D