Can't get Shift Out Register (74hc595) to loop with 8 LEDs

Hello all,

I implemented the solution for the 8 LED’s controlled by the 74hc595 chip. What happened was the LED’s came on and stayed on for about 500ms. Then all the LED’s turned off and have never come back on again. I tested the resistors and they are still reading 220 ohms as expected.
Has anyone come across this behavior before? Any idea what could be going on?

I did power cycle the UNO and tried re-uploading the firmware without any changes. The LED’s never came back. Powering the resistor manually does turn the LED on again as expected.

This is what can happen when you wire things wrong. Exactly what you wired wrong is hard to say from that mass of wires, especially as you have not posted any schematic.

Maybe the power to the chip was backwards, or too much voltage for the chip.

From what I can make out you do not seem to be using the correct pins for the power supply to the chip.



I realized that the attached pictures were not going to be of much use. There is only so much I can do with those breadboard wires in a confined space I didn’t want to cut and shorten them as I want to reuse the ones I have.

I was hoping someone would be able to assist based on the described behavior.

I didn’t have a proper schematic to go by as the tutorial only had the attached image to use as a reference. They only mentioned 4 pins and the rest was up to you to decode the image.

Turned out I was missing the other 5v bridge between pins 10 and 16.

So is it working now or have you blown the chip?

The yellow wire from the Arduino seems connected to pin10 of the chip. Must go to pin11. Pin10 should be connected directly to +5volt. Leo..

Grumpy_Mike: So is it working now or have you blown the chip?

It worked perfectly after attaching the other 5v lead. There was no damage done to the chip as the other wiring was all correct; only the additional 5v line in was missing.