Can't initialize Arduino Wifi Shield

Hello everyone..

I have bought a Arduino Wifi Shield (http://arduino.cc/en/Main/ArduinoWiFiShield) and are trying to get it to work with my Arduino Uno Rev3 but without any success. = (

I following each step in the Guide (http://arduino.cc/en/Guide/ArduinoWiFiShield) and have uploaded the exemple code in the guide "Scan for available networks". I have tried it with Arduino IDE 1.0.2 and the 1.0.5. Nothing works =( In the serial monitor I only get the message "Initializing Wifi" and nothing more..

What is wrong? Is the shield broken? Do I need some external power to the shield? Right now I'm just using the USB cabel between the computer and the Arduino UNO.

Any suggestions? I have "googled" for hours now and still not even close to a solution..

Try this test sketch. Does it display “WiFi shield not present” or the firmware version?

#include <WiFi.h>
#include <SPI.h>

void setup() {
  Serial.begin(9600); 

  // disable SD SPI
  pinMode(4,OUTPUT);
  digitalWrite(4,HIGH);

  // check for the presence of the shield:
  if (WiFi.status() == WL_NO_SHIELD) {
    Serial.println("WiFi shield not present"); 
    // don't continue:
    while(true);
  } 

  // check firmware version
  Serial.print(F("Firmware version: "));
  Serial.println(WiFi.firmwareVersion());.
}

void loop() {
}

Hello Tim and thanks for your respond…

I did as you said but the serial monitor display nothing… not “wifi shield not present” or the firmware version. I tried it on both Arduino IDE 1.0.2 and 1.0.5.

I tested to add the code-line serial.print(“Hello”); just before the if (Wifi.status() … line and then the monitor displayed “Hello” but no status or firmwire version regarding the Wifi shield.

Insure you do not have a jumper on the DFU programming pins. Those are the two pins next to the SD slot.

Otherwise it sounds like you have a defective wifi shield.

Thank’s again for your reply.

I don’t have a jumper on the DFU programming pins but I may have found the problem = (

It seems like the pins for ICSP-communication are burned (see attached image-file). So I would go for that the shield is broken =(

Thank’s for your help anyway =)