Can't load Arduino Nano Driver on Windows 10 PC

Windows 10 previously used an Arduino Uno with no problem.

Genuine Arduino Nano. In fact I tried a second. Neither work.
FT232rl on the nano chip
Atmel m3289 on the small square chip

In device manager FT232R appears under “other devices”
If I open it it states:

The drivers for this device are not installed. (Code 28)

There are no compatible drivers for this device.

To find a driver for this device, click Update Driver.

I open “Update Driver”
Automatic update provides nothing.
Browse my computer → I open the folder “FTDI USB Drivers”
There is no executable file in this folder.

I’ve tried downloading a second driver folder. Same thing. No exe file.

Please help.

There is no exe file for the FTDI driver, GOOGLE : Update driver on windows xxx
Replace xxx with your version of windows.

Just did that. This is what I got.

Update drivers in Windows 10

  1. In the search box on the taskbar, enter device manager, then select Device Manager.
  2. Select a category to see names of devices, then right-click (or press and hold) the one you’d like to update.
  3. Select Search automatically for updated driver software.
  4. Select Update Driver.

I’ve already done that as stated above. No dice.

Did you try adding 2.12.28 from here?
https://ftdichip.com/drivers/vcp-drivers/
That’s what I have on my Win10 laptop.

Thanks. That seems to have worked. I’m going to restart now and try to upload my script. :slight_smile:

Unfortunately it didn’t work. Windows did say that the driver installed correctly. However the nano will still not upload.

Here’s what I did.
This link https://ftdichip.com/drivers/vcp-drivers/
Chose 2.12.28 Downloaded to PC
→ Device manager → Now the FTDI doesn’t appear as unknown device.
USB controllers → USB serial converter → General FTDI Port_#0005.Hub_#0001
The device is working properly.

However, when I try to upload my sketch I get the this error message.

Arduino: 1.8.13 (Windows 10), Board: “Arduino Nano, ATmega328P”

Sketch uses 19974 bytes (65%) of program storage space. Maximum is 30720 bytes.

Global variables use 1045 bytes (51%) of dynamic memory, leaving 1003 bytes for local variables. Maximum is 2048 bytes.

C:\Users\Happyhome 2\Desktop\Arduino\hardware\tools\avr/bin/avrdude -CC:\Users\Happyhome 2\Desktop\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM1 -b115200 -D -Uflash:w:C:\Users\HAPPYH~2\AppData\Local\Temp\arduino_build_457409/sketch_apr20b.ino.hex:i

avrdude: Version 6.3-20190619

     Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

     Copyright (c) 2007-2014 Joerg Wunsch



     System wide configuration file is "C:\Users\Happyhome 2\Desktop\Arduino\hardware\tools\avr/etc/avrdude.conf"



     Using Port                    : COM1

     Using Programmer              : arduino

     Overriding Baud Rate          : 115200

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x93

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x93

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x93

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x93

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x93

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x93

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x93

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x93

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x93

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x93

avrdude done. Thank you.

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with
“Show verbose output during compilation”
option enabled in File → Preferences.

Ok. Got it to work. I just had to change the port to com 4. I’m sooooooo happy. Thanks everyone for your help!!!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.