Can't open Arduino anymore on mac Big Sur

Hi--I am on a macbook pro and as recently as a few weeks back, I was able to use the Arduino app. However, today I tried to open it, and while the initial window pops up and goes through "Initializing Packages" and "Starting", the app never opens after that.

I am on macOS 11.4 (Big Sur) (which admittedly updated fully today, but I was on an earlier version of Big Sur a few weeks back, and Arduino ran fine). I've tried a few different version of Arduino at this point:
--Arduino IDE 2.0.0 beta (this had a different result--see below)

I've updated my Java and JDK. I've tried to follow the steps in this thread below, but I don't even find the file that is suggested to be edited. I've tried emptying out the contents of the Arduino15 folder (except preferences.txt). I've restarted my computer multiple times.

NOTHING WORKS! Each time I just get the attempted startup, and then nothing. The only thing that sort of comes close to opening the app is going into the packages folder and clicking on the MacOS Arduino Unix executable file (which launches the terminal). Then a few of my recent sketches open up in arduino, but I can't open anything else.

For Arduino IDE, when I open that, I keep getting just one sketch file opening, and I can't create or open another in the same app.

Help? I'm not a sophisticated user, so please if you have any advice, make it really basic and step-by-step. I know I can use the online version, but I really would like to get the app to work on my mac.

(PS I have the same conditions on my other MacBook pro--same OS, updated Java, Arduino 1.8.13, and it all works fine. Not sure what the difference is here!!)


Please provide a detailed description of what you mean by that. What happens when you attempt to open something else? If there is an error message, please post the full and exact message.

So when I try to open Arduino or any arduino sketch, the initialization/welcome window pops up (the one with the logo and the little doodles and the attributions). At the bottom, it says "Initializing packages...." then after a while, that message changes to "Starting..." and then after that, the app closes.

PS I do have the same configuration on my other mac (OS 11.4, Arduino 1.8.13, updated Java) and it works completely fine. So not sure what the difference is here.

Please do this:

  1. Open your Applications folder.
  2. Open Utilities.
  3. Double-click on "Terminal".
  4. Type open Arduino
  5. Press Enter
  6. Wait for the Arduino IDE to finish starting, or failing to start. If it starts, attempt to open a sketch, or whatever action it is that causes the failure.
  7. Switch back to the terminal window if the Arduino IDE window took the focus.
  8. Press Cmd+A. This will select all the text in the terminal window.
  9. Press Cmd+C. This will copy the selected text to the clipboard.
  10. Open a forum reply here by clicking the Reply button.
  11. Click the </> icon on the post composer toolbar. This will add the forum's code block markup (```) to your reply to make sure the error messages are correctly formatted.
    Code block
  12. Press Ctrl+V. This will paste the compilation output into the code block.
  13. Move the cursor outside of the code block markup before you add any additional text to your reply.
  14. Click the Reply button to post the output.

Hopefully that will give us some information we can use to help you with the problem.

1 Like

Hi--so I actually solved the problem by completely uninstalling Arduino (including the app, the Arduino15 folder and the sketchbook folder), then emptying the trash. Then I chose to install Arduino 1.8.13 since I know that one works on my other Mac with OS Big Sur. Seems like that solved my problem. Something must have gotten corrupted in the old installation.

I'm glad to hear it's working now. Thank you for taking the time to post an update. Enjoy!

It seems many others have this problem. The best solution I have found is using Homebrew in the Terminal according to these instructions

After updating to OpenJDK, both the Arduino IDE and Teensyduino extension will load as they should.

This is what worked for me too: delete the app (from the Applications folder), as well as ~/Documents/Arduino and ~/Library/Arduino15, and then reinstall everything. This was a bit painful, as I'm using an ESP32-based board, and had to go through Adafruit's instructions for getting the ESP32 stuff.

One oddity though ... My app (an MIT App Inventor app which controls the Arduino) stores data in the board's EEPROM. When the app starts up, it reads the stored data from the EEPROM. After the re-install it was getting the wrong values - i.e. not the values the app had written to the EEPROM before the re-installation. Apparently something changed in the addressing of EEPROM locations.

1 Like
I have the same problem. Arduino v1.8.19 will not start

So as a data point, I am currently on Mac OS 12.0.1 (Monterrey), and I can get 1.8.19 to start. But I should note that, prior to installing that last week, I had been on v.1.8.15, thinking that older versions were more debugged. But then I started having problems with that version (including it feeding too high a voltage to my GEMMA). So I deleted that version, installed 1.8.16, but then after a day, that version started not functioning (meaning that I couldn't open sketches on it anymore). So I deleted that version, skipped 1.8.18, and installed 1.8.19. So far it's working, but I find my Arduino installs on my Mac somewhat unstable because pretty frequently I have to reinstall it.

PS you might try reinstalling your Arduino again just to reset everything. Or roll back to a previous version.


I am on:

Hardware Overview:

Model Name: iMac

Model Identifier: iMac15,1

Processor Name: Quad-Core Intel Core i7

Processor Speed: 4 GHz

Number of Processors: 1

Total Number of Cores: 4

L2 Cache (per Core): 256 KB

L3 Cache: 8 MB

Hyper-Threading Technology: Enabled

Memory: 32 GB

System Firmware Version: 432.

SMC Version (system): 2.23f11

Serial Number (system): C02NT5LYFY14

Hardware UUID: E2078A38-D52D-5061-9F38-6B27A7088D61

Provisioning UDID: E2078A38-D52D-5061-9F38-6B27A7088D61

It looks like more or less the same problem.

I have uninstalled Arduino v1.8.19, moved the Arduino folder to the waste bin and emptied the bin.

Then looked for any Arduino installs. None to be found.

Surprise, surprise, there is an Arduino v 1.8.13 somewhere on the hard disk. Where I would not have a clue. It opens like it should. Can compile programs as long as the necessary libraries are also installed.

I had Arduino v1.8.19 running as it should but suddenly a day later if failed to open. Then via the Content folder I could open v1.18.19 together with the terminal open. Now that does not work anymore either. T now only opens in exec style and nothing else.

Arduino v2.0 seems to work but is still a bit of a dark horse. Probably patience is the only solution until they have released v2.0 as a stable version.

Not only the Mac gives me problems, Windows10 or for that matter all Window OS gives the same. When in preferences I copy the link for eg. The ESP32 boards, it copies all right but will not paste in the Preference box. Like something is blocking it from copying into the Arduino software. I am not that flexible anymore. I am 78 and brains are a bit difficult in remembering certain actions. Normally Google is your friend but did not give me any clues either. Well just struggle on.

Thanks for answering my query.


Eb W.

type or paste code hereLast login: Thu Jan  6 17:10:20 on ttys000
/Applications/ ; exit;
ebwijkstra@Ebs-iMac ~ % /Applications/ ; exit;
2022-01-06 17:11:52.426 Arduino[2789:82730] Loading Application 'Arduino'
2022-01-06 17:11:52.427 Arduino[2789:82730] JVMRuntime=jre8u252-b09.jre
2022-01-06 17:11:52.427 Arduino[2789:82730] CFBundleName=Arduino
2022-01-06 17:11:52.427 Arduino[2789:82730] WorkingDirectory=(null)
2022-01-06 17:11:52.427 Arduino[2789:82730]
2022-01-06 17:11:52.427 Arduino[2789:82730] JVMOptions=(
2022-01-06 17:11:52.427 Arduino[2789:82730] JVMArguments=(
2022-01-06 17:11:52.427 Arduino[2789:82730] JVMClasspath=(null)
2022-01-06 17:11:52.427 Arduino[2789:82730] JVMDefaultOptions={
2022-01-06 17:11:52.427 Arduino[2789:82730] SearchSystemJVM=false
2022-01-06 17:11:52.427 Arduino[2789:82730] -> Bundle path: /Applications/
2022-01-06 17:11:52.427 Arduino[2789:82730] -> Working Directory: '/Users/ebwijkstra'
2022-01-06 17:11:52.427 Arduino[2789:82730] -> JVM Runtime path: /Applications/
2022-01-06 17:11:52.428 Arduino[2789:82730] -> Java Runtime Dylib Path: '/Applications/'
2022-01-06 17:11:52.434 Arduino[2789:82730] Command line passed to application argc=21:
2022-01-06 17:11:52.434 Arduino[2789:82730] Arg 0: '/Applications/'
2022-01-06 17:11:52.434 Arduino[2789:82730] Arg 1: '-Djava.class.path=/Applications/'
2022-01-06 17:11:52.434 Arduino[2789:82730] Arg 2: '-Djava.library.path=/Applications/'
2022-01-06 17:11:52.434 Arduino[2789:82730] Arg 3: '-DLibraryDirectory=/Users/ebwijkstra/Library'
2022-01-06 17:11:52.434 Arduino[2789:82730] Arg 4: '-DDocumentsDirectory=/Users/ebwijkstra/Documents'
2022-01-06 17:11:52.434 Arduino[2789:82730] Arg 5: '-DApplicationSupportDirectory=/Users/ebwijkstra/Library/Application Support'
2022-01-06 17:11:52.434 Arduino[2789:82730] Arg 6: '-DCachesDirectory=/Users/ebwijkstra/Library/Caches'
2022-01-06 17:11:52.434 Arduino[2789:82730] Arg 7: '-DSandboxEnabled=true'
2022-01-06 17:11:52.435 Arduino[2789:82730] Arg 8: ''
2022-01-06 17:11:52.435 Arduino[2789:82730] Arg 9: ''
2022-01-06 17:11:52.435 Arduino[2789:82730] Arg 10: ''
2022-01-06 17:11:52.435 Arduino[2789:82730] Arg 11: '-DAPP_DIR=/Applications/'
2022-01-06 17:11:52.435 Arduino[2789:82730] Arg 12: '-Djava.ext.dirs=/Applications/'
2022-01-06 17:11:52.435 Arduino[2789:82730] Arg 13: ''
2022-01-06 17:11:52.435 Arduino[2789:82730] Arg 14: '-Xdock:name=Arduino'
2022-01-06 17:11:52.435 Arduino[2789:82730] Arg 15: ''
2022-01-06 17:11:52.435 Arduino[2789:82730] Arg 16: '-Dfile.encoding=UTF-8'
2022-01-06 17:11:52.435 Arduino[2789:82730] Arg 17: '-Xms128M'
2022-01-06 17:11:52.435 Arduino[2789:82730] Arg 18: '-Xmx512M'
2022-01-06 17:11:52.435 Arduino[2789:82730] Arg 19: '-splash:/Applications/'
2022-01-06 17:11:52.435 Arduino[2789:82730] Arg 20: ''
2022-01-06 17:11:52.436 Arduino[2789:82741] Loading Application 'Arduino'
2022-01-06 17:11:52.436 Arduino[2789:82741] JVMRuntime=jre8u252-b09.jre
2022-01-06 17:11:52.436 Arduino[2789:82741] CFBundleName=Arduino
2022-01-06 17:11:52.436 Arduino[2789:82741] WorkingDirectory=(null)
2022-01-06 17:11:52.436 Arduino[2789:82741]
2022-01-06 17:11:52.436 Arduino[2789:82741] JVMOptions=(
2022-01-06 17:11:52.436 Arduino[2789:82741] JVMArguments=(
2022-01-06 17:11:52.436 Arduino[2789:82741] JVMClasspath=(null)
2022-01-06 17:11:52.436 Arduino[2789:82741] JVMDefaultOptions={
2022-01-06 17:11:52.436 Arduino[2789:82741] SearchSystemJVM=false
2022-01-06 17:11:52.436 Arduino[2789:82741] -> Bundle path: /Applications/
2022-01-06 17:11:52.436 Arduino[2789:82741] -> Working Directory: '/Users/ebwijkstra'
2022-01-06 17:11:52.436 Arduino[2789:82741] -> JVM Runtime path: /Applications/
2022-01-06 17:11:52.436 Arduino[2789:82741] -> Java Runtime Dylib Path: '/Applications/'
2022-01-06 17:11:52.437 Arduino[2789:82741] Command line passed to application argc=21:
2022-01-06 17:11:52.437 Arduino[2789:82741] Arg 0: '/Applications/'
2022-01-06 17:11:52.437 Arduino[2789:82741] Arg 1: '-Djava.class.path=/Applications/'
2022-01-06 17:11:52.438 Arduino[2789:82741] Arg 2: '-Djava.library.path=/Applications/'
2022-01-06 17:11:52.438 Arduino[2789:82741] Arg 3: '-DLibraryDirectory=/Users/ebwijkstra/Library'
2022-01-06 17:11:52.438 Arduino[2789:82741] Arg 4: '-DDocumentsDirectory=/Users/ebwijkstra/Documents'
2022-01-06 17:11:52.438 Arduino[2789:82741] Arg 5: '-DApplicationSupportDirectory=/Users/ebwijkstra/Library/Application Support'
2022-01-06 17:11:52.438 Arduino[2789:82741] Arg 6: '-DCachesDirectory=/Users/ebwijkstra/Library/Caches'
2022-01-06 17:11:52.438 Arduino[2789:82741] Arg 7: '-DSandboxEnabled=true'
2022-01-06 17:11:52.438 Arduino[2789:82741] Arg 8: ''
2022-01-06 17:11:52.438 Arduino[2789:82741] Arg 9: ''
2022-01-06 17:11:52.438 Arduino[2789:82741] Arg 10: ''
2022-01-06 17:11:52.438 Arduino[2789:82741] Arg 11: '-DAPP_DIR=/Applications/'
2022-01-06 17:11:52.438 Arduino[2789:82741] Arg 12: '-Djava.ext.dirs=/Applications/'
2022-01-06 17:11:52.438 Arduino[2789:82741] Arg 13: ''
2022-01-06 17:11:52.438 Arduino[2789:82741] Arg 14: '-Xdock:name=Arduino'
2022-01-06 17:11:52.438 Arduino[2789:82741] Arg 15: ''
2022-01-06 17:11:52.438 Arduino[2789:82741] Arg 16: '-Dfile.encoding=UTF-8'
2022-01-06 17:11:52.438 Arduino[2789:82741] Arg 17: '-Xms128M'
2022-01-06 17:11:52.438 Arduino[2789:82741] Arg 18: '-Xmx512M'
2022-01-06 17:11:52.438 Arduino[2789:82741] Arg 19: '-splash:/Applications/'
2022-01-06 17:11:52.438 Arduino[2789:82741] Arg 20: '' /Users/ebwijkstra/Library/Arduino15 (Is a directory)
	at Method)
	at cc.arduino.contributions.packages.ContributionsIndexer.parseIndex(
	at cc.arduino.contributions.packages.ContributionsIndexer.mergeContributions(
	at cc.arduino.contributions.packages.ContributionsIndexer.parseIndex(
Saving session...
...copying shared history...
...saving history...truncating history files...

[Process completed]

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.