Can't open Serial monitor on Arduino IDE!

Hey everyone .

So I’m kinda new to arduino and i have a problem with my Serial monitor on Arduino IDE.

Every time I try opening the Serial monitor this message appears:

Exception in thread “AWT-EventQueue-0” java.lang.UnsatisfiedLinkError: C:\Users??? ???.jssc\windows\jSSC-2.8_x86.dll: Can’t find dependent libraries
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(
at java.lang.ClassLoader.loadLibrary(
at java.lang.Runtime.load0(
at java.lang.System.load(
at jssc.SerialNativeInterface.(
at jssc.SerialPort.(
at javax.swing.AbstractButton.fireActionPerformed(
at javax.swing.AbstractButton$Handler.actionPerformed(
at javax.swing.DefaultButtonModel.fireActionPerformed(
at javax.swing.DefaultButtonModel.setPressed(
at javax.swing.AbstractButton.doClick(
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(
at java.awt.Component.processMouseEvent(
at javax.swing.JComponent.processMouseEvent(
at java.awt.Component.processEvent(
at java.awt.Container.processEvent(
at java.awt.Component.dispatchEventImpl(
at java.awt.Container.dispatchEventImpl(
at java.awt.Component.dispatchEvent(
at java.awt.LightweightDispatcher.retargetMouseEvent(
at java.awt.LightweightDispatcher.processMouseEvent(
at java.awt.LightweightDispatcher.dispatchEvent(
at java.awt.Container.dispatchEventImpl(
at java.awt.Window.dispatchEventImpl(
at java.awt.Component.dispatchEvent(
at java.awt.EventQueue.dispatchEventImpl(
at java.awt.EventQueue.access$500(
at java.awt.EventQueue$
at java.awt.EventQueue$
at Method)
at java.awt.EventQueue$
at java.awt.EventQueue$
at Method)
at java.awt.EventQueue.dispatchEvent(
at java.awt.EventDispatchThread.pumpOneEventForFilters(
at java.awt.EventDispatchThread.pumpEventsForFilter(
at java.awt.EventDispatchThread.pumpEventsForHierarchy(
at java.awt.EventDispatchThread.pumpEvents(
at java.awt.EventDispatchThread.pumpEvents(

In case anyone knows something about it please tell me!
Thank you!


It's the 1.8.9 version of arduino IDE and windows 10.

Try re installing it, I had the same problem, and try tó download the hourly work.
Hourly work doesent have a lot of bugs.
And try installing java.

I mean, I ran the same arduino board to another pc without java and it worked perfectly fine. I have re-installed it plenty of times too and the issue doesn't seem to be fixed at all.

If you have installed multiple times maybe there is some remnants that need to be cleared out.
Attaching some clean up instructions that may be of help.

Is this YOUR own personal computer ?
It should NOT be a company or loaned computer and if it is you should talk to your IT administrator to get an upgraded profile. Even more so if your company uses “Bit locker” as you are unlikely to be able to run the IDE without the Bit locker key.

Are you the ONLY user ?
If you are a secondary user in any way your permissions may not be high enough to access all the files or folders you may need to in order to run the IDE properly. This can be fixed by the primary user or the IT department who are often able to give you the correct permissions and or status.

Are you on a company or educational network or any other form of network ?
The Ide can be exceptionally fussy to run over a network unless you fully understand what you are doing. If you don’t then talk to your local network guru.

Do you have Administrator priviledges ? (real ones not just pseudo user admin)
If you are a Primary user you may still have limited options depending on who and how your computer was set up. Luckily there are quite easy options to give yourself the FULL admin rights. NOTE that the full administrator account can be dangerous is not used with care and is better turned off after each use. Simply google “run with administrative” and google will do the rest in giving you lots of methods to do that. Its simple and quick.

What security do you use AV etc etc ? ( list them all ! )
Antivirus and some other security software will actively block parts of the IDE from operating and even on occasion issue a false positive warning about a virus. If you got your IDE from the reputable source of then you have nothing to worry about.
You can tell your security software to IGNORE the Arduino software and or folders. If you get a virus warning you are better off to submit it to the respective AV Company and advise them of its status as a false positive. Many AV allow you to white list or exclude programs and those options change with different software so it is in your interest to figure that out.

Have you tried to use just an unzipped version of the IDE ?
Usually this is a last resort but if you download the ZIPPED version of the IDE and extract it to a folder you can quite often run it from there. If it works for you simply set up a shortcut to it on your desktop.

Another option is to change the location of your sketches folder.
You can do this from the preferences inside the IDE.
It may be worth moving it OUTSIDE your documents folder or even to another drive.

Simply create the folder you wish to use and then point the IDE to that location.


Well I have tried deleting all the remenant files of the IDE through some guide at google and it failed . I'll try it the way the pdf suggests .Now about the Pc, it's completely MINE and I built it so I don't think there's an issue there. Furthermore, I don't really run any antivirus just firewall. Although, when in the past I tried letting specifically the app of IDE go through the firewall it wasn't even on the list of apps. No, I've never used a zipped version of IDE and I don't really know what this means as a 16-yo to be honest. I will try deleting the remenant files or (if that fails) relocating the sketches some time later because I'm kinda busy right now and I will let you know.

Excuse me for my poor English writing skills!

Thank you for your time

Another issue some users face is network or cloud based storage installations.

Where possible avoid them unless you know a little about them.
Google drive and OneDrive can be especially problematic.

So apparently I tried deleting the "arduino 15" file which I never found at the appData(local, low local, roaming) so I continued with downloading revouninstaller as you suggested.The arduino IDE was at the windows apps(in case that helps), and i just deleted the remenants of the app. When I downloaded it again my previous code appeared like nothing happened as well as the same message. Tried relocating the sketchbook to another drive but nothing changed. Moreover I'm pretty sure there's no network based installation.

Thank you for your time again.

The arduino IDE was at the windows apps

Do I understand correctly that you're using the Windows store version? If so, uninstall and use the normal version "for WinXP and up".

The Windows store version is known to show unexpected behaviour at occasion.

I have the same problem, tried some other resources, but not able the solve the exact problem!

Help will be appreciated!

I tried downloading the xp version and up. It let me download the exe file, but wouldn't let me go further as an invisible window pops up named "window dialog"(Not responding) and after a while of waiting another window named "NSIS Error" pops up with a message saying error launching installer.

It certainly sounds like a permissions or security issue at this point.

When was the last time you did a full and proper scan for nasties ?
preferably using a reputable online scanner !

You gave me a hint with the NSIS error.
There are multiple hits in google for how to fix that BUT…they may just mask an underlying issue which is why you may want to spend the time with a COMPLETE security audit.

If you wish I can provide some steps to do that but they can be a little time consuming depending on your hardware ?

So eventually I downloaded the arduino (xp and up) version from another pc and transfered it with a usb to mine. Suprisingly, it worked and now I can officially say that I'm able to open the serial monitor. I should thank you all guys for the significant help and the fact that you all spent time trying to solve the problem. Ballscrewbob I really wish you could provide me with some steps and it would be heavily appreciated.Don't worry my hardware is in a pretty good position.

Again, thank you all guys for the help!

The main thing here is not to use the computer for anything else whilst following the steps below

Use the initial clean up instructions already provided first but only in terms of CCLEANER and the WISE reg cleaner. That will remove a lot of crud from your computer and speed up the checking process.

Use the link I gave for ESET and run that to its completion.
If it finds anything let it deal with those issues.

Download and install MalwareBytes (free version)
Run it to its completion and let it deal with anything it finds.

Go back to step one and re-do. It will help clean any remnants found in steps 2 and 3.

Please run each thing to its completion before starting on the next step.

If you have anything nasty you may at some point need to perform a roll back to a known good restore point (assuming you have them set up). On some very serious occasions even a complete re-install of the OS may be required. (If you have proper back ups this is an easy process).

If you come across something you cannot handle then a good tech guy may be worth the expense.

Thank you so much for the help!