Can't program Arduino Nano a second time [Solved]

Hi,

I just got my new and shiny Arduino Nano and I started with a simple program using interrupts:

void setup()
{
  attachInterrupt(0, earLeft, FALLING);
  attachInterrupt(1, earRight, FALLING);
  
  Serial.begin(9600);
}

void loop()
{
  // empty
}

void earLeft()
{
  Serial.println("Left!");
}

void earRight()
{
  Serial.println("Right!");
}

And it works nice.

The thing is: I wanted to change it and upload a new version and I'm getting this error message:

Binary sketch size: 2,466 bytes (of a 30,720 byte maximum)
/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/bin/avrdude -C/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -carduino -P/dev/tty.usbserial-14P03928 -b57600 -D -Uflash:w:/var/folders/f1/snvcgdns4x7gsdhfwy2y645m0000gp/T/build5340009852939150166.tmp/test_interrupciones.cpp.hex:i 

avrdude: Version 5.11, compiled on Sep  2 2011 at 18:52:52
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf"
         User configuration file is "/Users/diego/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/tty.usbserial-14P03928
         Using Programmer              : arduino
         Overriding Baud Rate          : 57600
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

avrdude done.  Thank you.

I can't upload anything anymore.

I've tried with Arduino v1.0.5 and Arduino 1.5.6-r2 BETA. I'm using MacOSX 10.9.2 (and I already tried rebooting the computer).

I can see in the serial monitor that my previous program is still running (despite all my attempts to overwrite it).

Any help is appreciated. Thanks.

(deleted)

Thanks, that solved my issue.

I have to push the reset button always when uploading the sketch, even though after uploading the BareMinimum example. Didn't have to the first time.

Also I found in the documentation for the micro that procedure: http://arduino.cc/en/Guide/ArduinoLeonardoMicro?from=Guide.ArduinoLeonardo#toc12 I think the documentation of the Nano should be updated to link to that page.