Can't programm Arduino Pro Mini

Hello,
a while ago I put a programm on my Arduino pro mini 5V 16mhz and it worked fine. Now, a few months later I wanted to edit the code, but I couldn't write code to it.
I am able to see the Serial Port with changing data comming out, so the communication is working but when I try to upload code I get the "avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
" error message. To programm my Arduino I used the CP2102 before, but I also tried it programming with a UNO. With both methodes I can read the outcomming Data but not change the code.

Edit: I have nothing else connected to the Arduino

Anyone can help me?

Did you connect the DTR from the programmer to the ProMini?

No, I haven't used the DTR, because the schemattic doesnt show that and last time it worked without that, besides that my normal programmer (CP2102) doesn't even come with a DTR or Reset function.

I now tried it with Reset and DTR directly connected (Uno methode), but it didnt worked. Sadly I have no other Pro mini to eliminate a harware issue.

But thanks for the hint!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.