Can't start Arduino022, launch4j error, Windows 7

Very frustrating, I've used Arduino program for many months and I am now having a big problem. When I tryto launch the program I get the opening screen and then it seems to freeze. After several minutes I get a "launch4j" error message. "an error occurred when starting the application".

After many hours of searching on the net I've tried the following without luck:

Completely removed and reinstalled both latest Java and Arduino022 Disabled wireless mouse Disabled antivirus program Disabled wireless internet Launched as Administrator

Any help would be greatly appreciated.

A really cool F-35 VTOL project has come to a grinding halt because of this.

http://www.youtube.com/watch?v=IExL2cVaZQ4

Is this a bug in Windows 7, Java or Arduino 022?

Do you have the Java Runtime Environment installed? http://www.oracle.com/technetwork/java/javase/downloads/index.html

Edit: Insure you have installed the correct version. There is a 32 bit and a 64 bit version.

I uninstalled and removed all previous java files using JavaRa. Fresh load of windows x86 version of Java. Still no joy.

If this is a 64bit version of winblows: I think I've recently read a post where somebody claimed that installing 32bit apps to a 'Program Files(x86)' folder did the trick. I wouldn't know why and how, but maybe it helps.

My other suggestion would be: "format c:\" (don't).

I used the 32 bit version. No luck.

I had the same problem with Win Vista. It began after a Windows Auto Update process had problems. I tried the Restore process, no luck. I tried everything referenced above, no luck.

I finally scrammed the HD and restored from backup. THAT worked.

Dave.