can't start - can't upload (

Hey
I just get my arduino!
But I can’t start…
When i try to upload my first program (blinking led), I got:
avrdude: ser_open(): can’t open device “\.\COM1”: The system cannot find the file specified.

And also, I cant find drivers to windows 10 64 bit. I attaching what i see.

Anyone? :frowning:

Seriously doubt your Arduino is on COM1.

Hey, how I can do that?

roeyfu:
Hey, how I can do that?

Do what?

  1. Have you selected the correct port from Tools -> Port? If no entries there, or if none of them correspond to the board (ie, if they don't disappear when you unplug the arduino)

  2. What kind of Arduino do you have?

  3. Is it an official board, or might it be a clone? Many boards are sold as Arduino boards that are actually clones (the official ones are much more expensive, and come in a box with Arduino branding).

  4. If it is a clone of a Nano/ProMini/Uno/Mega, or if you don't know whether it is a clone, locate the black integrated circuit close to the USB connector. This will likely say either 16u2 (or 8u2), CH340G, CP2102, or FT232RL. If it says 16u2, the drivers are included with the IDE, and if you install via the installer, they will be installed for you automatically. If it's CH340G or CP2102, google the part number, your OS version, and the word drivers, download, install.

  5. Try using a different USB cable. Many USB cables that come with Arduino kits lately are defective.

  6. If using a USB 3.0 port, try using a USB 2.0 port. USB 3.0 ports often have backwards compatibility issues with USB 2.0 devices.

  7. Do you get the "new hardware found" noise when you plug it in?

  8. Does device manager show an unknown device?

Many thanks DrAzzy. You solved two of my problems. One switching to a USB 2.0 and the other a cause for my insufficient power. Again...thank you.

Hi i'm a middle school student trying to install arduino IDE 1.8.5 for my 64 bit linux dell laptop. When I download it I just get boxes and folders but nothing will open and I don't know how to "extract into a sutible folder" when we did make a folder and tried to extract the files it fails to run the installation scrip in our terminal. Could someone please help me? Again, I am a middle school student.

AquaChalllengers1:
Hi i'm a middle school student trying to install arduino IDE 1.8.5 for my 64 bit linux dell laptop. When I download it I just get boxes and folders but nothing will open and I don't know how to "extract into a sutible folder" when we did make a folder and tried to extract the files it fails to run the installation scrip in our terminal. Could someone please help me? Again, I am a middle school student.

Please start your own thread with your question.

Your post has nothing to do with the original question, and what you are doing is hijacking a thread which is a no-no.