cant upload a program

yo, so i got today an arduino uno from china, pretty sure its a clone.
i installed the drivers needed and its on the right port
when im trying to upload a program the error is
Arduino:1.8.12 (Windows 10), לוח:"Arduino Uno"

סקיצה משתמשת ב924 (2%) מתוך נפח האחסון התוכנה הזמין. הנפח מקסימלי הינו 32256 בייט.
משתנים גלובלים משתמשים ב9 בייט (0%) של זיכרון דינמי, משאירים 2039 בייט לאחסון משתנים מקומיים. מרב המקום הינו 2048 בייט.
C:\Users\omerb\Downloads\arduino-1.8.12-windows\arduino-1.8.12\hardware\tools\avr/bin/avrdude -CC:\Users\omerb\Downloads\arduino-1.8.12-windows\arduino-1.8.12\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM3 -b115200 -D -Uflash:w:C:\Users\omerb\AppData\Local\Temp\arduino_build_495704/Blink.ino.hex:i

avrdude: Version 6.3-20190619
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is "C:\Users\omerb\Downloads\arduino-1.8.12-windows\arduino-1.8.12\hardware\tools\avr/etc/avrdude.conf"

Using Port : COM3
Using Programmer : arduino
Overriding Baud Rate : 115200
avrdude: ser_open(): can't set com-state for "\.\COM3"

avrdude done. Thank you.

אירעה שגיאה במהלך העלאת סקיצה

דו"ח זה היה יכול להיות מפורט יותר אם האופציה
"Show verbose output during compilation"
הייתה מופעלת בתפריט 'קובץ -> העדפות'.

Try restarting your computer. Sometimes a glitch causes the port to get stuck in a bad state and restarting fixes that.

Language problem ?
Try a language closer to your native language:

pert:
Try restarting your computer. Sometimes a glitch causes the port to get stuck in a bad state and restarting fixes that.

still didnt help... heres the error
avrdude: ser_open(): can't set com-state for "\.\COM3"
can someone tell pls what can the problem be??? maybe beacuse its a clone??

Clones often need additional drivers.

COMMON ISSUES

  • Check you have a COMMON GROUND where required.
  • Where possible use USB 2.0 ports or a USB 2.0 POWERED HUB to rule out USB 3.0 issues.
  • Try other computers where possible.
  • Try other USB leads where possible.
  • You may not have the correct driver installed. CH340/341 or CP2102
  • There may be a problem with the board check your wiring first.
  • Remove any items connected to pins 0 and 1.
  • Boards using a MICRO usb connector need a cable that is both DATA and CHARGE. Many are CHARGE ONLY.

COMPUTER RELATED

  • close any other serial programs before opening the IDE.
  • Ensure you turn off any additional security / antivirus just to test.
  • There may be a problem with the PC try RESTARTING it.
  • You may be selecting the wrong COM port.
  • Avoid cloud/network based installations where possible OR ensure your Network/Cloud software is RUNNING.
  • Clear your browsers CACHE.
  • Close the IDE before using any other serial programs.
  • Preferably install IDE's as ADMINISTRATOR or your OS equivalent

Arduino specific boards

  • CH340/341 based clones do not report useful information to the "get board info" button.
  • NANO (Old Types) some require you to use the OLD BOOTLOADER option.
  • NANO (New Types) See the specific sections lower in the forum.
  • NANO (New Types) Install your board CORE's.
  • Unless using EXTERNAL PROGRAMMERS please leave the IDE selection at default "AVRISP mkII".

tried everything none of it helped... pls guys can someone try figure out what it could be?
if it helps, when i connect the uno to my pc the ON light turns red and the L spot flashes rapidly
i tried installing the drivers literally from everywhere (LLC,ISL...) using the arduino.inf
what can the problem be???

PROBLEM SOLVED I INSTALLED THE CH341SER.EXE AND IT WORKS FINE NOW TNX:)

LOL then you didn't try "everything" the first time around as I gave t you the link to the drivers.

Glad you got going.
Enjoy your Arduino adventures.